summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-04-25 18:33:00 +0100
committerChristopher Baines <mail@cbaines.net>2022-04-25 18:33:00 +0100
commita14c6352662bfa6715ec70b3d280a6d1d599ad0c (patch)
tree11885ba06728921af7a6fb9fd3bf293a8633e0b7
parentd0f6b8d7b07665f22231338c2cc9ebf1b6ff7de2 (diff)
downloadguix-patches-a14c6352662bfa6715ec70b3d280a6d1d599ad0c.tar
guix-patches-a14c6352662bfa6715ec70b3d280a6d1d599ad0c.tar.gz
gnu: nginx-rtmp-module: Fix builder.
Probably broken by changes to the nginx package in 4079cd9ba33b0d2cd23897899dfc66836797e4d2 . * gnu/packages/web.scm (nginx-rtmp-module)[arguments]: Make the modify-phases part a gexp, and move #:configure-flags to the end of the list.
-rw-r--r--gnu/packages/web.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ee74a4385d..0b629c0269 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -786,34 +786,34 @@ programming language.")))
,@(package-inputs nginx)))
(arguments
(substitute-keyword-arguments
- `(#:configure-flags '("--add-dynamic-module=.")
- #:make-flags '("modules")
+ `(#:make-flags '("modules")
#:modules ((guix build utils)
(guix build gnu-build-system))
- ,@(package-arguments nginx))
+ ,@(package-arguments nginx)
+ #:configure-flags '("--add-dynamic-module=."))
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'unpack-nginx-sources
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (begin
- ;; The nginx source code is part of the module’s source.
- (format #t "decompressing nginx source code~%")
- (invoke "tar" "xvf" (assoc-ref inputs "nginx-sources")
- ;; This package's LICENSE file would be
- ;; overwritten with the one from nginx when
- ;; unpacking the nginx source, so rename the nginx
- ;; one when unpacking.
- "--transform=s,/LICENSE$,/LICENSE.nginx,"
- "--strip-components=1")
- #t)))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((modules-dir (string-append (assoc-ref outputs "out")
- "/etc/nginx/modules")))
- (install-file "objs/ngx_rtmp_module.so" modules-dir)
- #t)))
- (delete 'fix-root-dirs)
- (delete 'install-man-page)))))
+ #~(modify-phases #$phases
+ (add-after 'unpack 'unpack-nginx-sources
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (begin
+ ;; The nginx source code is part of the module’s source.
+ (format #t "decompressing nginx source code~%")
+ (invoke "tar" "xvf" (assoc-ref inputs "nginx-sources")
+ ;; This package's LICENSE file would be
+ ;; overwritten with the one from nginx when
+ ;; unpacking the nginx source, so rename the nginx
+ ;; one when unpacking.
+ "--transform=s,/LICENSE$,/LICENSE.nginx,"
+ "--strip-components=1")
+ #t)))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((modules-dir (string-append (assoc-ref outputs "out")
+ "/etc/nginx/modules")))
+ (install-file "objs/ngx_rtmp_module.so" modules-dir)
+ #t)))
+ (delete 'fix-root-dirs)
+ (delete 'install-man-page)))))
(home-page "https://github.com/arut/nginx-rtmp-module")
(synopsis "NGINX module for audio and video streaming with RTMP")
(description "This NGINX module provides streaming with the @acronym{RTMP,