summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-04-18 22:58:06 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-18 22:58:06 +0200
commit5389c5ea57dd17e19412f38dc448b0a5114a3579 (patch)
treefcc1461c1c8ce01703b00971b803a61e502ed377
parent902099a8c0fae2288d1da6d2da683b251b492691 (diff)
downloadguix-patches-5389c5ea57dd17e19412f38dc448b0a5114a3579.tar
guix-patches-5389c5ea57dd17e19412f38dc448b0a5114a3579.tar.gz
gnu: nss-certs: Support cross-compilation.
Reported by phodina <phodina@protonmail.com>. * gnu/packages/certs.scm (nss-certs)[arguments]: In 'install' phase, do not refer to '%output' when cross-compiling.
-rw-r--r--gnu/packages/certs.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 28c2f84f98..d410b05860 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016-2017, 2021-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -169,7 +169,12 @@ that was originally contributed to Debian.")
'(set-paths install-locale unpack))
(add-after 'unpack 'install
(lambda _
- (let ((certsdir (string-append %output "/etc/ssl/certs/")))
+ ;; TODO: On the next rebuild cycle, remove references to
+ ;; '%output' and '%outputs'.
+ (let ((certsdir (string-append ,(if (%current-target-system)
+ '(assoc-ref %outputs "out")
+ '%output)
+ "/etc/ssl/certs/")))
(with-directory-excursion "nss/lib/ckfw/builtins/"
(unless (file-exists? "blacklist.txt")
(call-with-output-file "blacklist.txt" (const #t)))