summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Prat <vprat@deeplinks.com>2022-04-08 16:29:38 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-15 19:13:02 +0200
commit4ed02d571a53f5a1e108a4df0bc3bf12a28fb0ed (patch)
tree678e4d5de506b97355c47bce2efd608b7c210a4c
parent304c6b395cdf0cd5ca911c428e08dbb06e37a8c5 (diff)
downloadguix-patches-4ed02d571a53f5a1e108a4df0bc3bf12a28fb0ed.tar
guix-patches-4ed02d571a53f5a1e108a4df0bc3bf12a28fb0ed.tar.gz
gnu: Add python-verspec.
* gnu/packages/python.xyz.scm (python-verspec): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 03b157de5c..219a0d9213 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29476,6 +29476,34 @@ database from the asyncio (PEP-3156/tulip) framework. It wraps
asynchronous features of the Psycopg database driver.")
(license license:bsd-3)))
+(define-public python-verspec
+ (package
+ (name "python-verspec")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "verspec" version))
+ (sha256
+ (base32
+ "07n06wv85fm4vl1ird2mja0823js3x322wgs9gdnq1djjyk4ql64"))))
+ (build-system python-build-system)
+ (native-inputs (list python-coverage python-flake8 python-mypy
+ python-pretend python-pytest))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "touch" "test/__init__.py")
+ (invoke "pytest")))))))
+ (home-page "https://github.com/jimporter/verspec")
+ (synopsis "Flexible version handling for Python")
+ (description
+ "This Python library handles software versions and specifiers. It is
+adapted from the @code{packaging} package.")
+ (license (list license:bsd-2 license:asl2.0))))
+
(define-public python-shtab
(package
(name "python-shtab")