summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-04-05 15:12:57 -0400
committerLudovic Courtès <ludo@gnu.org>2022-04-18 23:23:54 +0200
commit283088f7b158815a58ca687147860e2a6b8112ba (patch)
treeed14187e6845a0dfdcb8b17ff8b02cb297bb78ff
parentfc2d94a3f95b3a8f6e469fdd3cb92bdf110e1bd2 (diff)
downloadguix-patches-283088f7b158815a58ca687147860e2a6b8112ba.tar
guix-patches-283088f7b158815a58ca687147860e2a6b8112ba.tar.gz
gnu: Add python-sre-yield.
* gnu/packages/python-xyz.scm (python-sre-yield): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7193d4e6ce..9a5d311680 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -118,6 +118,7 @@
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29511,3 +29512,25 @@ adapted from the @code{packaging} package.")
"This package automatically generates shell tab completion scripts for
Python CLI apps.")
(license license:asl2.0)))
+
+(define-public python-sre-yield
+ (package
+ (name "python-sre-yield")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sre_yield" version))
+ (sha256
+ (base32
+ "12kv3mvdr22g2v9wfr5aabh1f58s817dbh8mrlfzxzxs7hm1lkz9"))))
+ (build-system python-build-system)
+ (native-inputs (list python-nose))
+ (home-page "https://github.com/google/sre_yield")
+ (synopsis "Expands a regular expression to its possible matches")
+ (description
+ "The goal of sre_yield is to efficiently generate all values that can
+match a given regular expression, or count possible matches efficiently. It
+uses the parsed regular expression, so you get a much more accurate result
+than trying to just split strings.")
+ (license license:asl2.0)))