summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-07-30 17:19:34 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-31 01:03:24 +0200
commitfa2d94b5e362c684da812d494463d965e601c18d (patch)
treec1d65cd1497bf947a3d83a064539266e62d06723
parent2b55f914c3198f9b07399d10502fbdb22b7d6e47 (diff)
downloadguix-patches-fa2d94b5e362c684da812d494463d965e601c18d.tar
guix-patches-fa2d94b5e362c684da812d494463d965e601c18d.tar.gz
gnu: python-onnx: Rename to "onnx".
* gnu/packages/machine-learning.scm (python-onnx): Rename to... (onnx): ... this, and change 'name' field accordingly. (python-onnx): New variable. * gnu/packages/patches/python-onnx-shared-libraries.patch: Rename to... * gnu/packages/patches/onnx-shared-libraries.patch: ... this. * gnu/packages/patches/python-onnx-use-system-googletest.patch: Rename to... * gnu/packages/patches/onnx-use-system-googletest.patch: ... this. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk4
-rw-r--r--gnu/packages/machine-learning.scm14
-rw-r--r--gnu/packages/patches/onnx-shared-libraries.patch (renamed from gnu/packages/patches/python-onnx-shared-libraries.patch)0
-rw-r--r--gnu/packages/patches/onnx-use-system-googletest.patch (renamed from gnu/packages/patches/python-onnx-use-system-googletest.patch)0
4 files changed, 12 insertions, 6 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 798560ca95..e6c03cbe55 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1512,6 +1512,8 @@ dist_patch_DATA = \
%D%/packages/patches/ocaml-dose3-Install-mli-cmx-etc.patch \
%D%/packages/patches/omake-fix-non-determinism.patch \
%D%/packages/patches/oneko-remove-nonfree-characters.patch \
+ %D%/packages/patches/onnx-use-system-googletest.patch \
+ %D%/packages/patches/onnx-shared-libraries.patch \
%D%/packages/patches/openbabel-fix-crash-on-nwchem-output.patch \
%D%/packages/patches/opencascade-oce-glibc-2.26.patch \
%D%/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch \
@@ -1633,8 +1635,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-memcached-syntax-warnings.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-testtools.patch \
- %D%/packages/patches/python-onnx-use-system-googletest.patch \
- %D%/packages/patches/python-onnx-shared-libraries.patch \
%D%/packages/patches/python-packaging-test-arch.patch \
%D%/packages/patches/python2-parameterized-docstring-test.patch \
%D%/packages/patches/python-paste-remove-timing-test.patch \
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 1cea91977f..75faeb8eb8 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -581,16 +581,16 @@ tools. This enables both rapid prototyping of data pipelines and extensibility
in terms of new algorithms.")
(license license:gpl3+)))
-(define-public python-onnx
+(define-public onnx
(package
- (name "python-onnx")
+ (name "onnx")
(version "1.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "onnx" version))
- (patches (search-patches "python-onnx-use-system-googletest.patch"
- "python-onnx-shared-libraries.patch"))
+ (patches (search-patches "onnx-use-system-googletest.patch"
+ "onnx-shared-libraries.patch"))
(sha256
(base32 "0yjv2axz2vc2ysniwislsp53fsb8f61y1warrr2ppn2d9ijml1d9"))
(modules '((guix build utils)))
@@ -658,6 +658,12 @@ computation graph model, as well as definitions of built-in operators and
standard data types.")
(license license:expat)))
+(define-public python-onnx
+ ;; This used to be called "python-onnx" because it provided nothing but
+ ;; Python bindings. The package now provides shared libraries and C++
+ ;; headers, hence the name change.
+ (deprecated-package "python-onnx" onnx))
+
(define-public rxcpp
(package
(name "rxcpp")
diff --git a/gnu/packages/patches/python-onnx-shared-libraries.patch b/gnu/packages/patches/onnx-shared-libraries.patch
index 00583b35da..00583b35da 100644
--- a/gnu/packages/patches/python-onnx-shared-libraries.patch
+++ b/gnu/packages/patches/onnx-shared-libraries.patch
diff --git a/gnu/packages/patches/python-onnx-use-system-googletest.patch b/gnu/packages/patches/onnx-use-system-googletest.patch
index 5dfcbc6dc3..5dfcbc6dc3 100644
--- a/gnu/packages/patches/python-onnx-use-system-googletest.patch
+++ b/gnu/packages/patches/onnx-use-system-googletest.patch