summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominic Martinez <dom@dominicm.dev>2022-04-11 13:58:44 -0400
committerLudovic Courtès <ludo@gnu.org>2022-04-15 19:13:03 +0200
commitc6c0c985d34bb4fed4bd997c5349d9d0886a4d29 (patch)
treeae4ad9f62bdc4d5c46c7a3315077b8f0b38fe3d0
parent6995d6843596e38e4452a8b775d572dd2f26c64b (diff)
downloadguix-patches-c6c0c985d34bb4fed4bd997c5349d9d0886a4d29.tar
guix-patches-c6c0c985d34bb4fed4bd997c5349d9d0886a4d29.tar.gz
gnu: emacs-mu4e-patch: Rename to emacs-message-view-patch
The name was changed upstream to reflect that this extension works for both mu4e and gnus. * gnu/packages/emacs-xyz.scm (emacs-mu4e-patch): Deprecate it. (emacs-message-view-patch): Renamed from emacs-mu4e-patch. Description, synopsis, and inputs adjusted to reflect that mu4e is not required. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d95421472..905a0b914e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13300,32 +13300,33 @@ automatically using existing List-ID headers in your mu database. Just press
automatically discovered and presented in recency order.")
(license license:gpl3+))))
-(define-public emacs-mu4e-patch
+(define-public emacs-message-view-patch
(let ((commit "522da46c1653b1cacc79cde91d6534da7ae9517d")
(revision "1"))
(package
- (name "emacs-mu4e-patch")
+ (name "emacs-message-view-patch")
(version (git-version "0.1.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/seanfarley/mu4e-patch")
+ (url "https://github.com/seanfarley/message-view-patch")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
"10lzf3b70pk6rzdrgx0ww0gc94v0ydh9zj1gbsa20xw27ds7hmfn"))))
(build-system emacs-build-system)
- (propagated-inputs
- (list mu))
(home-page "https://github.com/seanfarley/mu4e-patch")
- (synopsis "Colorize patch-like emails in mu4e")
+ (synopsis "Colorize patch-like emails in mu4e or gnus")
(description
- "Extension for mu4e to colorize patch-like emails with diff-mode.
+ "Extension for mu4e or gnus to colorize patch-like emails with diff-mode.
This is based on Frank Terbeck's @code{gnus-article-treat-patch.el} but has
-been adapted to work with mu4e.")
+been adapted to also work with mu4e.")
(license license:gpl3+))))
+(define-public emacs-mu4e-patch
+ (deprecated-package "emacs-mu4e-patch" emacs-message-view-patch))
+
(define-public emacs-pretty-mode
(package
(name "emacs-pretty-mode")