summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-04-01 16:22:20 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-04-14 11:34:03 -0400
commit8f5b2f0693e8cf60f97e045fd502aece4d4767f1 (patch)
tree4a35f00c11aa81d2c49e75639c1eee91808f588a
parent0ddca9d682013f10b7e0137878ab68363d929167 (diff)
downloadguix-patches-8f5b2f0693e8cf60f97e045fd502aece4d4767f1.tar
guix-patches-8f5b2f0693e8cf60f97e045fd502aece4d4767f1.tar.gz
gnu: Add emacs-org-modern.
* gnu/packages/emacs-xyz.scm (emacs-org-modern): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 005f34e569..2d95421472 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30811,6 +30811,28 @@ audio volume via amixer.")
Fennel code within Emacs.")
(license license:gpl3+)))
+(define-public emacs-org-modern
+ (package
+ (name "emacs-org-modern")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/org-modern")
+ (commit version)))
+ (sha256
+ (base32 "187fxw2rg0kw1d2binpa32ckp67r4v10j6ypr077g9qn6nkmyvvn"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/minad/org-modern")
+ (synopsis "Modern Org Style")
+ (description
+"@code{emacs-org-modern} implements a modern style for your Org
+buffers using font locking and text properties. The package styles
+headlines, keywords, tables and source blocks.")
+ (license license:gpl3+)))
+
(define-public emacs-osm
(package
(name "emacs-osm")