summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-13 23:21:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-13 23:43:06 +0200
commitfb4c0efbb1d38edec7d939ba59ebd38672788cdc (patch)
tree05b9bc7b8c86afeb6dab2ce4ae4cda449cdc3740
parent0bd926b6e45ae0316583ef7079e988f6ea640fb6 (diff)
downloadguix-patches-fb4c0efbb1d38edec7d939ba59ebd38672788cdc.tar
guix-patches-fb4c0efbb1d38edec7d939ba59ebd38672788cdc.tar.gz
gnu: fakeroot: Invoke an absolute cat.
* gnu/packages/linux.scm (fakeroot)[arguments]: Refer to ‘cat’ by its absolute file name.
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4a54fd954b..b34e00233d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7871,9 +7871,9 @@ the superuser to make device nodes.")
(("sed")
(string-append (assoc-ref inputs "sed")
"/bin/sed"))
- (("cut")
+ (("cat|cut" command)
(string-append (assoc-ref inputs "coreutils")
- "/bin/cut")) )))
+ "/bin/" command)) )))
(replace 'bootstrap
(lambda _
;; The "preroll" script takes care of Autoconf and also