summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-17 10:35:40 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-17 10:37:35 +0200
commit05f8943f048c30920b0a6dd546400d7c19740d10 (patch)
treebe187f31ccaa71f36c277b2515b51e8b7259b139
parent15b283e712a23cbffc9a50bebc8bca94283a3fe6 (diff)
downloadguix-patches-05f8943f048c30920b0a6dd546400d7c19740d10.tar
guix-patches-05f8943f048c30920b0a6dd546400d7c19740d10.tar.gz
gnu: emacs-helm-system-packages: Add recutils to inputs.
* gnu/packages/emacs.scm (emacs-helm-system-packages)[inputs]: Use recutils.
-rw-r--r--gnu/packages/emacs.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f7ee26179a..57841e86fa 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5929,8 +5929,20 @@ Yasnippet.")
(base32
"01by0c4lqi2cw8xmbxkjw7m9x78zssm31sx4hdpw5j35s2951j0f"))))
(build-system emacs-build-system)
+ (inputs
+ `(("recutils" ,recutils)))
(propagated-inputs
`(("emacs-helm" ,emacs-helm)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((recutils (assoc-ref inputs "recutils")))
+ ;; Specify the absolute file names of the various
+ ;; programs so that everything works out-of-the-box.
+ (substitute* "helm-system-packages-guix.el"
+ (("recsel") (string-append recutils "/bin/recsel")))))))))
(home-page "https://github.com/emacs-helm/helm-system-packages")
(synopsis "Helm System Packages is an interface to your package manager")
(description "List all available packages in Helm (with installed