summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2018-10-13 18:32:14 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2018-11-19 12:01:48 +0100
commitdf0a180421b34b6f1f3395652291f94a37303988 (patch)
tree49bcd5c93ef4f65e802e7e011097f2b65121c5ec
parent28e32b14e4b3139a8bda294d3cc0efd33f286998 (diff)
downloadguix-patches-df0a180421b34b6f1f3395652291f94a37303988.tar
guix-patches-df0a180421b34b6f1f3395652291f94a37303988.tar.gz
gnu: clojure: Remove 'remove-archives' snippet.
This is no longer needed since clojure now makes official source releases in github. * gnu/packages/lisp.scm (clojure)[source]: Remove it. [native-inputs]: Remove it in 'submodule'. [arguments]: Adjust 'unpack-submodule-sources' phase accordingly.
-rw-r--r--gnu/packages/lisp.scm24
1 files changed, 7 insertions, 17 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 0e07e1969e..f963dfb5de 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -566,18 +566,12 @@ interface.")
license:clarified-artistic)))) ;TRIVIAL-LDAP package
(define-public clojure
- (let* ((remove-archives '(begin
- (for-each delete-file
- (find-files "." ".*\\.(jar|zip)"))
- #t))
- (submodule (lambda (prefix version hash)
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/clojure/"
- prefix version ".tar.gz"))
- (sha256 (base32 hash))
- (modules '((guix build utils)))
- (snippet remove-archives)))))
+ (let ((submodule (lambda (prefix version hash)
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/clojure/"
+ prefix version ".tar.gz"))
+ (sha256 (base32 hash))))))
(package
(name "clojure")
(version "1.9.0")
@@ -588,9 +582,7 @@ interface.")
(string-append "https://github.com/clojure/clojure/archive/clojure-"
version ".tar.gz"))
(sha256
- (base32 "0xjbzcw45z32vsn9pifp7ndysjzqswp5ig0jkjpivigh2ckkdzha"))
- (modules '((guix build utils)))
- (snippet remove-archives)))
+ (base32 "0xjbzcw45z32vsn9pifp7ndysjzqswp5ig0jkjpivigh2ckkdzha"))))
(build-system ant-build-system)
(arguments
`(#:modules ((guix build ant-build-system)
@@ -609,8 +601,6 @@ interface.")
(mkdir-p name)
(with-directory-excursion name
(invoke "tar"
- ;; Use xz for repacked tarball.
- "--xz"
"--extract"
"--verbose"
"--file" (assoc-ref inputs name)