summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-04-19 21:54:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-04-19 21:56:50 +0300
commitffb616b69dced25b840f2e5178062072d89623eb (patch)
treeaae2f37acbf9b370da49412f1169391567da886f
parent0b681c58964975237a2ceb3c1951f8934740f1f8 (diff)
downloadguix-patches-ffb616b69dced25b840f2e5178062072d89623eb.tar
guix-patches-ffb616b69dced25b840f2e5178062072d89623eb.tar.gz
gnu: vcflib: Update to 1.0.3.
* gnu/packages/bioinformatics.scm (vcflib): Update to 1.0.3. [source]: Remove trailing #t. [arguments]: Remove trailing #t from phases.
-rw-r--r--gnu/packages/bioinformatics.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8f2f69530f..4634b86515 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14478,7 +14478,7 @@ library automatically handles index file generation and use.")
(define-public vcflib
(package
(name "vcflib")
- (version "1.0.2")
+ (version "1.0.3")
(source
(origin
(method git-fetch)
@@ -14487,7 +14487,7 @@ library automatically handles index file generation and use.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1k1z3876kbzifj1sqfzsf3lgb4rw779hvkg6ryxbyq5bc2paj9kh"))
+ (base32 "1r7pnajg997zdjkf1b38m14v0zqnfx52w7nbldwh1xpbpahb1hjh"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -14510,8 +14510,7 @@ library automatically handles index file generation and use.")
(("Fasta.h") "fastahack/Fasta.h"))
(for-each delete-file-recursively
'("fastahack" "filevercmp" "fsom" "googletest" "intervaltree"
- "libVCFH" "multichoose" "smithwaterman"))
- #t))))
+ "libVCFH" "multichoose" "smithwaterman"))))))
(build-system cmake-build-system)
(inputs
(list bzip2
@@ -14540,8 +14539,7 @@ library automatically handles index file generation and use.")
(substitute* "CMakeLists.txt"
(("vcflib STATIC") "vcflib SHARED"))
(substitute* "test/Makefile"
- (("libvcflib.a") "libvcflib.so"))
- #t))
+ (("libvcflib.a") "libvcflib.so"))))
(add-after 'unpack 'unpack-submodule-sources
(lambda* (#:key inputs #:allow-other-keys)
(let ((unpack (lambda (source target)
@@ -14556,8 +14554,7 @@ library automatically handles index file generation and use.")
(unpack "filevercmp-src" "filevercmp")
(unpack "fsom-src" "fsom")
(unpack "intervaltree-src" "intervaltree")
- (unpack "multichoose-src" "multichoose"))
- #t)))
+ (unpack "multichoose-src" "multichoose")))))
;; This pkg-config file is provided by other distributions.
(add-after 'install 'install-pkg-config-file
(lambda* (#:key outputs #:allow-other-keys)