summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-19 15:28:56 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-19 15:38:24 +0100
commita21b88f10cabd94636d72284c5b435ba814f125e (patch)
treea0f334c54537ff71d32e31c92a8a628a4b948102
parent74471036f63d5b4d578cd79972221100d992d7e1 (diff)
downloadguix-patches-a21b88f10cabd94636d72284c5b435ba814f125e.tar
guix-patches-a21b88f10cabd94636d72284c5b435ba814f125e.tar.gz
gnu: wireless-tools: Fix cross-compilation.
* gnu/packages/linux.scm (wireless-tools)[arguments]: Replace 'configure phase to substitute CC, AR and RANLIB Makefile variables to suitable values when cross-compiling.
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bea10b1bdd..8a02c353b1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2831,8 +2831,20 @@ mapper. Kernel components are part of Linux-libre.")
(string-append "INSTALL_MAN=" %output "/share/man")
(string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")
"BUILD_STATIC=")
- #:phases (modify-phases %standard-phases
- (delete 'configure))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key target #:allow-other-keys)
+ (when ,(%current-target-system)
+ ;; Cross-compilation: use the cross tools.
+ (substitute* (find-files "." "Makefile")
+ (("CC = .*$")
+ (string-append "CC = " target "-gcc\n"))
+ (("AR = .*$")
+ (string-append "AR = " target "-ar\n"))
+ (("RANLIB = .*$")
+ (string-append "RANLIB = " target "-ranlib\n"))))
+ #t)))
#:tests? #f))
(synopsis "Tools for manipulating Linux Wireless Extensions")
(description "Wireless Tools are used to manipulate the now-deprecated