summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-04-13 16:12:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-14 12:33:27 +0200
commit55be5fc400ed30cceca279de13dcbe270b60fee4 (patch)
treecf3ed01a1735deb3fe6a72c66a62d0a333a1cf69
parent08df30f232afc1fc1ae7fb3c9889b5ad96bc5dea (diff)
downloadguix-patches-55be5fc400ed30cceca279de13dcbe270b60fee4.tar
guix-patches-55be5fc400ed30cceca279de13dcbe270b60fee4.tar.gz
gnu: Add r-acme.
* gnu/packages/bioconductor.scm (r-acme): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d3e16cd859..8664f1139f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -11661,6 +11661,33 @@ storing these data. Basic methods are accessing/replacing, subsetting,
printing and plotting @code{aCGH} objects.")
(license license:gpl2)))
+(define-public r-acme
+ (package
+ (name "r-acme")
+ (version "2.50.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ACME" version))
+ (sha256
+ (base32
+ "0h4bqbbqcwc938q7lysk5l35f64xz9d1bsniv2wshmlr4rr0zpcg"))))
+ (properties `((upstream-name . "ACME")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase r-biocgenerics))
+ (home-page "https://bioconductor.org/packages/aCGH/")
+ (synopsis "Calculating microarray enrichment")
+ (description
+ "This package implements @dfn{algorithms for calculating microarray
+enrichment} (ACME), and it is a set of tools for analysing tiling array of
+@dfn{combined chromatin immunoprecipitation with DNA microarray} (ChIP/chip),
+DNAse hypersensitivity, or other experiments that result in regions of the
+genome showing enrichment. It does not rely on a specific array technology
+(although the array should be a tiling array), is very general (can be applied
+in experiments resulting in regions of enrichment), and is very insensitive to
+array noise or normalization methods. It is also very fast and can be applied
+on whole-genome tiling array experiments quite easily with enough memory.")
+ (license license:gpl2+)))
+
;; This is a CRAN package, but it depends on Bioconductor packages, so we put
;; it here.
(define-public r-activedriverwgs