summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-04-16 00:51:49 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-04-19 20:28:01 +0200
commit5376f3d058b91469d1f6daa56e4ffcef42ae34e4 (patch)
tree4c573002669d0c66365b2ad82dd205523bf9c31f
parent4df82befc9dfeeddb64ec671cef5f3bc8c770dce (diff)
downloadguix-patches-5376f3d058b91469d1f6daa56e4ffcef42ae34e4.tar
guix-patches-5376f3d058b91469d1f6daa56e4ffcef42ae34e4.tar.gz
gnu: openttd-openmsx: Use new package style.
* gnu/packages/games.scm (openttd-openmsx)[arguments]: Convert to list of G-Expressions. [native-inputs]: Drop labels.
-rw-r--r--gnu/packages/games.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f5555b519a..5cb79375e0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4413,27 +4413,28 @@ the original Transport Tycoon Deluxe.")
"0h583d8fxy78kc3jvpp78r76a48qhxrhm4q7jbnj74aw0kwrcl8g"))))
(build-system gnu-build-system)
(native-inputs
- `(("grfcodec" ,grfcodec)
- ; Scripts are Python3 compatible, but call the interpreter as
- ; python instead of python3.
- ("python" ,python-wrapper)
- ("tar" ,tar)))
+ (list grfcodec
+ ;; Scripts are Python3 compatible, but call the interpreter as
+ ;; python instead of python3.
+ python-wrapper
+ tar))
(arguments
- `(#:make-flags
- (list (string-append "DIR_NAME=openmsx")
- (string-append "TAR="
- (search-input-file %build-inputs "/bin/tar")))
- ;; The check phase only verifies md5sums, see openttd-opengfx.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (copy-recursively "openmsx"
- (string-append (assoc-ref outputs "out")
- "/share/games/openttd/baseset"
- "/openmsx")))))))
+ (list
+ #:make-flags
+ #~(list (string-append "DIR_NAME=openmsx")
+ (string-append "TAR="
+ (search-input-file %build-inputs "/bin/tar")))
+ ;; The check phase only verifies md5sums, see openttd-opengfx.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively "openmsx"
+ (string-append (assoc-ref outputs "out")
+ "/share/games/openttd/baseset"
+ "/openmsx")))))))
(home-page "http://dev.openttdcoop.org/projects/openmsx")
(synopsis "Music set for OpenTTD")
(description "OpenMSX is a music set for OpenTTD which makes it possible