summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-14 14:07:53 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-14 20:31:59 +0200
commit5059e7f01e1d299a2a52b1649251fa49f1992385 (patch)
treea23f118b9cab30e998cfb912ba37a2669d6a0fa9
parent8f5b2f0693e8cf60f97e045fd502aece4d4767f1 (diff)
downloadguix-patches-5059e7f01e1d299a2a52b1649251fa49f1992385.tar
guix-patches-5059e7f01e1d299a2a52b1649251fa49f1992385.tar.gz
gnu: cl-py4cl: Update to 0.0.0-1.2f2a008.
* gnu/packages/lisp-xyz.scm (sbcl-py4cl): Update to 0.0.0-1.2f2a008. [arguments]<#:phases>: Adjust substitutions to renamed files. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ca61723df7..d380bef94f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5183,8 +5183,8 @@ writing NumPy @file{.npy} and @file{.npz} files.")
(sbcl-package->ecl-package sbcl-numpy-file-format))
(define-public sbcl-py4cl
- (let ((commit "4c8a2b0814fd311f978964f825ce012290f60136")
- (revision "1"))
+ (let ((commit "2f2a008dd6162d4446803971292fe1b323fe0dd5")
+ (revision "2"))
(package
(name "sbcl-py4cl")
(version (git-version "0.0.0" revision commit))
@@ -5197,7 +5197,7 @@ writing NumPy @file{.npy} and @file{.npz} files.")
(file-name (git-file-name name version))
(sha256
(base32
- "15mk7qdqjkj56gdnbyrdyz6r7m1h26ldvn6ch96pmvg5vmr1m45r"))
+ "1zx1kpfpd8mi1qaa7gr32mki6nvl6pqcs3437fvn4xa3yf7ybsha"))
(modules '((guix build utils)))))
(build-system asdf-build-system/sbcl)
(native-inputs
@@ -5212,7 +5212,7 @@ writing NumPy @file{.npy} and @file{.npz} files.")
(modify-phases %standard-phases
(add-after 'unpack 'fix-python3-path
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/callpython.lisp"
+ (substitute* "src/python-process.lisp"
(("\\*python-command\\* \"python\"")
(string-append "*python-command* "
"\""
@@ -5225,7 +5225,7 @@ writing NumPy @file{.npy} and @file{.npz} files.")
;; source-code so lisp can call into "py4cl.py". We can
;; hard-code this since we know where this file will
;; reside.
- (substitute* "src/callpython.lisp"
+ (substitute* "src/python-process.lisp"
(("py4cl/config:\\*base-directory\\*")
(string-append
"\""