summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-04-16 00:49:31 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-04-19 20:28:01 +0200
commit4df82befc9dfeeddb64ec671cef5f3bc8c770dce (patch)
tree3c2bae6dbdcbcde61f9e5c375aef8c5e0b5a8e31
parent2bae85d39b5a440863e745c053ae43dfa047a3b7 (diff)
downloadguix-patches-4df82befc9dfeeddb64ec671cef5f3bc8c770dce.tar
guix-patches-4df82befc9dfeeddb64ec671cef5f3bc8c770dce.tar.gz
gnu: openttd-opensfx: Use new package style.
* gnu/packages/games.scm (openttd-opensfx)[arguments]: Convert to list of G-Expressions. Drop trailing ‘#t’s. [native-inputs]: Drop labels.
-rw-r--r--gnu/packages/games.scm54
1 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2e122ad05f..f5555b519a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4363,34 +4363,34 @@ OpenGFX provides you with...
"0aym026lg0r7dp3jxxs9c0rj8lwy1fz3v9hmk3mml6sycsg3fv42"))))
(build-system gnu-build-system)
(native-inputs
- `(("catcodec" ,catcodec)
- ("python" ,python)
- ("tar" ,tar)))
+ (list catcodec
+ python
+ tar))
(arguments
- `(#:make-flags
- (list (string-append "DIR_NAME=opensfx")
- (string-append "TAR="
- (search-input-file %build-inputs "/bin/tar")))
- ;; The check phase only verifies md5sums, see openttd-opengfx.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-reproducible
- (lambda _
- ;; Remove the time dependency of the installed tarball by setting
- ;; the modification times if its members to 0.
- (substitute* "scripts/Makefile.def"
- (("-cf") " --mtime=@0 -cf"))
- #t))
- (delete 'configure)
- (add-before 'build 'prebuild
- (lambda _ (invoke "make" "opensfx.cat")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (copy-recursively "opensfx"
- (string-append (assoc-ref outputs "out")
- "/share/games/openttd/baseset"
- "/opensfx")))))))
+ (list
+ #:make-flags
+ #~(list (string-append "DIR_NAME=opensfx")
+ (string-append "TAR="
+ (search-input-file %build-inputs "/bin/tar")))
+ ;; The check phase only verifies md5sums, see openttd-opengfx.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'make-reproducible
+ (lambda _
+ ;; Remove the time dependency of the installed tarball by setting
+ ;; the modification times if its members to 0.
+ (substitute* "scripts/Makefile.def"
+ (("-cf") " --mtime=@0 -cf"))))
+ (delete 'configure)
+ (add-before 'build 'prebuild
+ (lambda _ (invoke "make" "opensfx.cat")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively "opensfx"
+ (string-append (assoc-ref outputs "out")
+ "/share/games/openttd/baseset"
+ "/opensfx")))))))
(home-page "http://dev.openttdcoop.org/projects/opensfx")
(synopsis "Base sounds for OpenTTD")
(description "OpenSFX is a set of free base sounds for OpenTTD which make