summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-04-14 16:42:42 +0000
committerLudovic Courtès <ludo@gnu.org>2022-04-20 23:46:44 +0200
commit4bd4c53aace8a64e90c17117cf0cd89d5200c492 (patch)
tree0decfb788e588e9b0fbb714b831ebdc7cbbae59b
parent139970c8066fe5cfb6adbc20346a73c0a7cec202 (diff)
downloadguix-patches-4bd4c53aace8a64e90c17117cf0cd89d5200c492.tar
guix-patches-4bd4c53aace8a64e90c17117cf0cd89d5200c492.tar.gz
gnu: Add aws-c-sdkutils.
* gnu/packages/c.scm (aws-c-sdkutils): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/c.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 585624b57e..8f660a316e 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -727,6 +727,34 @@ cryptographic primitives for the @acronym{AWS,Amazon Web Services} SDK.")
(home-page "https://github.com/awslabs/aws-c-cal")
(license license:asl2.0)))
+(define-public aws-c-sdkutils
+ (package
+ (name "aws-c-sdkutils")
+ ; Update only when updating aws-crt-cpp.
+ (version "0.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14wpl3dxwjbbzas44v6m6m3ll89rgz34x9gb140qz624gwzs9v0v"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ (list "-DBUILD_SHARED_LIBS=ON"
+ (string-append "-DCMAKE_PREFIX_PATH="
+ (assoc-ref %build-inputs "aws-c-common")))))
+ (propagated-inputs
+ (list aws-c-common))
+ (synopsis "Amazon Web Service utility library")
+ (description "This library provides for parsing and management of profiles
+for the @acronym{AWS,Amazon Web Services} SDK.")
+ (home-page "https://github.com/awslabs/aws-c-sdkutils")
+ (license license:asl2.0)))
+
(define-public pcl
(package
(name "pcl")