summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-04-05 14:57:16 -0400
committerLudovic Courtès <ludo@gnu.org>2022-04-18 23:14:37 +0200
commit2aa5329023128168db2691ed26fb512f9dac0c48 (patch)
tree7ab925832cf50a3bfa85eb64409fd7d6a8534cc6
parenta76c879f1451088e82a610d456f45050a44c350a (diff)
downloadguix-patches-2aa5329023128168db2691ed26fb512f9dac0c48.tar
guix-patches-2aa5329023128168db2691ed26fb512f9dac0c48.tar.gz
gnu: Add python-quart.
* gnu/packages/python-web.scm (python-quart): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5fcfd27914..d77e310835 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -50,6 +50,7 @@
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6415,3 +6416,31 @@ Full documentation may be found at
(description "This package provides @code{Tweepy}, an easy-to-use Python
library for accessing the Twitter API.")
(license license:expat)))
+
+(define-public python-quart
+ (package
+ (name "python-quart")
+ (version "0.17.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Quart" version))
+ (sha256
+ (base32 "0h4n2dwzmqifya1razp9s7ppr4ra23ljac9v7sl039rzp3c17wic"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list hypercorn
+ python-aiofiles
+ python-blinker
+ python-click
+ python-itsdangerous
+ python-jinja2
+ python-markupsafe
+ python-toml
+ python-werkzeug))
+ (home-page "https://gitlab.com/pgjones/quart/")
+ (synopsis "Python ASGI web microframework with the same API as Flask")
+ (description
+ "This package provides a Python ASGI web microframework with the same API
+as Flask.")
+ (license license:expat)))