summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-04-14 16:39:37 +0000
committerLudovic Courtès <ludo@gnu.org>2022-04-20 23:46:43 +0200
commit25a1c60b1ca99e500d1bd909af85a08eeb2b0ae3 (patch)
tree5cb96b5860dc4928c3d5a23a80e3ea7e5ec5da02
parentbc3e32454f1641281a689fdbf9f4e1493dcf2157 (diff)
downloadguix-patches-25a1c60b1ca99e500d1bd909af85a08eeb2b0ae3.tar
guix-patches-25a1c60b1ca99e500d1bd909af85a08eeb2b0ae3.tar.gz
gnu: aws-lc: Update to 1.0.2.
* gnu/packages/tls.scm (aws-lc): Update to 1.0.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/tls.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f0595efe08..1a19f51ccc 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1190,28 +1190,27 @@ ciphers such as ChaCha20, Curve25519, NTRU, and Blake2b.")
(license license:gpl2+))) ; Audit
(define-public aws-lc
- (let ((commit "d0a5455417d80e68581e197d95720c3fb25e3926")
- (revision "0"))
- (package
- (name "aws-lc")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url (string-append "https://github.com/awslabs/" name))
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ysj3x1f2lcdvwzyb9x3waykz1j7r21viv5z5vgc0ja9xv7znm9g"))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f ; re-enable but with go and perl dependencies
- #:configure-flags
- '("-DBUILD_SHARED_LIBS=ON")))
- (synopsis "General purpose cryptographic library")
- (description "AWS libcrypto (aws-lc) contains portable C implementations
+ (package
+ (name "aws-lc")
+ ; Update only when updating aws-crt-cpp.
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14dhdddlph36nshdkh0v43718hxjx5vxqxmkw7707393q0qrgipw"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; re-enable but with go and perl dependencies
+ #:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (synopsis "General purpose cryptographic library")
+ (description "AWS libcrypto (aws-lc) contains portable C implementations
of algorithms needed for TLS and common applications, and includes optimized
assembly versions for x86 and ARM.")
- (home-page "https://github.com/awslabs/aws-lc")
- (license license:asl2.0))))
+ (home-page "https://github.com/awslabs/aws-lc")
+ (license license:asl2.0)))