summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:07:07 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:33:42 +0100
commit164b06daebe368124e22bd0d8810569b95438eeb (patch)
treed9d0edb7014db5649fb5a6a7f6d6f6f9994ec117
parentb42afab2e2aaa6415700a934c20d7dd0fb6f7834 (diff)
downloadguix-patches-164b06daebe368124e22bd0d8810569b95438eeb.tar
guix-patches-164b06daebe368124e22bd0d8810569b95438eeb.tar.gz
gnu: Add ocaml-ppx-here.
* gnu/packages/ocaml.scm (ocaml-ppx-here): New variable.
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 70ff74fe81..43a66e2ef5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5488,3 +5488,30 @@ many values).")
(synopsis "Syntax extension for writing in-line benchmarks in ocaml code")
(description "Syntax extension for writing in-line benchmarks in ocaml code.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-here
+ (package
+ (name "ocaml-ppx-here")
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/ppx_here-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wxcak3ay4jpigm3pfdcpr65qw4hxfa8whhkryhcd8gy71x056z5"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; broken tests
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_here")))
+ (home-page "https://github.com/janestreet/ppx_here")
+ (synopsis "Expands [%here] into its location")
+ (description
+ "Part of the Jane Street's PPX rewriters collection.")
+ (license license:asl2.0)))