summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-12 18:57:49 +0000
committerLudovic Courtès <ludo@gnu.org>2022-04-19 12:29:44 +0200
commit11e761b9a62a263054af5b68631460a57d375e80 (patch)
tree04a3faf2be5c387ae8cc3ba0371b9ed0e5f942b1
parent3a6703268b356e42e721fc2d86edcefa6a4dde88 (diff)
downloadguix-patches-11e761b9a62a263054af5b68631460a57d375e80.tar
guix-patches-11e761b9a62a263054af5b68631460a57d375e80.tar.gz
gnu: nomad-optimizer: Update to 4.2.0.
* gnu/packages/maths.scm (nomad-optimizer): Update to 4.2.0. [arguments]: Accommodate updated build process. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 26ce64de69..798d336525 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1937,17 +1937,17 @@ interfaces.")
(define-public nomad-optimizer
(package
(name "nomad-optimizer")
- (version "4.1.0")
+ (version "4.2.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/bbopt/nomad/")
- (commit (string-append "v" version))))
+ (commit (string-append "v." version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0w386d8r5ldbvnv0c0g7vz95pfpvwdxis26vaalk2amsa5akl775"))))
+ "1r4ygy3xn83dnppsw1451ynklsxpb238g5gk57inn84ghmdk08mj"))))
(build-system cmake-build-system)
(native-inputs
(list python-wrapper python-cython))
@@ -1959,7 +1959,8 @@ interfaces.")
(guix build cmake-build-system)
(guix build utils))
#:configure-flags
- '("-DBUILD_INTERFACES=ON"
+ '("-DBUILD_INTERFACE_C=ON"
+ "-DBUILD_INTERFACE_PYTHON=ON"
"-DBUILD_TESTS=ON")
#:phases
(modify-phases %standard-phases
@@ -1993,8 +1994,11 @@ interfaces.")
(substitute* "interfaces/PyNomad/setup_PyNomad.py"
(("^( +os_include_dirs = ).*" _ prefix)
(string-append prefix "[\"../../src\"]\n"))
- (("^(installed_lib_dir = ).*" _ prefix)
- (string-append prefix "\"" out "/lib\"\n"))))))
+ (("^(installed_lib_dir1 = ).*" _ prefix)
+ (string-append prefix "\"" out "/lib\"\n"))
+ (("^installed_lib_dir2 = .*") "")
+ (("^ +link_args\\.append\\(\"-Wl,-rpath,\" \\+ installed_lib_dir2\\)\n")
+ "")))))
;; Fix the tests so they run in out-of-source builds.
(add-after 'fix-sources-for-build 'fix-sources-for-tests