summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-14 13:37:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-14 13:37:23 +0200
commit03009f2a2bb5c94e94735d2ff9314502412066a4 (patch)
treef1a0ce4a11d266eea2a23cabd16525147fe78dd6
parentc8a6e4abbc4f279f919017d238576cf8724e9456 (diff)
downloadguix-patches-03009f2a2bb5c94e94735d2ff9314502412066a4.tar
guix-patches-03009f2a2bb5c94e94735d2ff9314502412066a4.tar.gz
gnu: r-snplocs-hsapiens-dbsnp144-grch37: Move to annotation section.
* gnu/packages/bioconductor.scm (r-snplocs-hsapiens-dbsnp144-grch37): Move this variable up to the annotation section.
-rw-r--r--gnu/packages/bioconductor.scm76
1 files changed, 38 insertions, 38 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f795b6ad9c..094bd0d907 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -775,6 +775,44 @@ Ensembl.")
Ensembl.")
(license license:artistic2.0)))
+(define-public r-snplocs-hsapiens-dbsnp144-grch37
+ (package
+ (name "r-snplocs-hsapiens-dbsnp144-grch37")
+ (version "0.99.20")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "SNPlocs.Hsapiens.dbSNP144.GRCh37"
+ version 'annotation))
+ (sha256
+ (base32
+ "1z8kx43ki1jvj7ms7pcybakcdimfwr6zpjvspkjmma97bdz093iz"))))
+ (build-system r-build-system)
+ ;; As this package provides little more than a very large data file it
+ ;; doesn't make sense to build substitutes.
+ (arguments `(#:substitutable? #f))
+ (propagated-inputs
+ (list r-biocgenerics
+ r-s4vectors
+ r-iranges
+ r-genomeinfodb
+ r-genomicranges
+ r-bsgenome
+ r-biostrings))
+ (home-page
+ "https://bioconductor.org/packages/SNPlocs.Hsapiens.dbSNP144.GRCh37/")
+ (synopsis "SNP locations for Homo sapiens (dbSNP Build 144)")
+ (description "This package provides SNP locations and alleles for Homo
+sapiens extracted from NCBI dbSNP Build 144. The source data files used for
+this package were created by NCBI on May 29-30, 2015, and contain SNPs mapped
+to reference genome GRCh37.p13. Note that the GRCh37.p13 genome is a
+patched version of GRCh37. However the patch doesn't alter chromosomes 1-22,
+X, Y, MT. GRCh37 itself is the same as the hg19 genome from UCSC *except* for
+the mitochondrion chromosome. Therefore, the SNPs in this package can be
+injected in @code{BSgenome.Hsapiens.UCSC.hg19} and they will land at the
+correct position but this injection will exclude chrM (i.e. nothing will be
+injected in that sequence).")
+ (license license:artistic2.0)))
+
(define-public r-txdb-dmelanogaster-ucsc-dm6-ensgene
(package
(name "r-txdb-dmelanogaster-ucsc-dm6-ensgene")
@@ -11271,44 +11309,6 @@ and parameters of which are trained on a set of aligned reads and a reference
genome sequence.")
(license license:lgpl3)))
-(define-public r-snplocs-hsapiens-dbsnp144-grch37
- (package
- (name "r-snplocs-hsapiens-dbsnp144-grch37")
- (version "0.99.20")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "SNPlocs.Hsapiens.dbSNP144.GRCh37"
- version 'annotation))
- (sha256
- (base32
- "1z8kx43ki1jvj7ms7pcybakcdimfwr6zpjvspkjmma97bdz093iz"))))
- (build-system r-build-system)
- ;; As this package provides little more than a very large data file it
- ;; doesn't make sense to build substitutes.
- (arguments `(#:substitutable? #f))
- (propagated-inputs
- (list r-biocgenerics
- r-s4vectors
- r-iranges
- r-genomeinfodb
- r-genomicranges
- r-bsgenome
- r-biostrings))
- (home-page
- "https://bioconductor.org/packages/SNPlocs.Hsapiens.dbSNP144.GRCh37/")
- (synopsis "SNP locations for Homo sapiens (dbSNP Build 144)")
- (description "This package provides SNP locations and alleles for Homo
-sapiens extracted from NCBI dbSNP Build 144. The source data files used for
-this package were created by NCBI on May 29-30, 2015, and contain SNPs mapped
-to reference genome GRCh37.p13. Note that the GRCh37.p13 genome is a
-patched version of GRCh37. However the patch doesn't alter chromosomes 1-22,
-X, Y, MT. GRCh37 itself is the same as the hg19 genome from UCSC *except* for
-the mitochondrion chromosome. Therefore, the SNPs in this package can be
-injected in @code{BSgenome.Hsapiens.UCSC.hg19} and they will land at the
-correct position but this injection will exclude chrM (i.e. nothing will be
-injected in that sequence).")
- (license license:artistic2.0)))
-
(define-public r-reqon
(package
(name "r-reqon")