summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-03-19 22:40:25 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-19 22:44:03 +0100
commit75431d509b22ea8ba07ece596f404827ced742f7 (patch)
treea1b13f46419d31e35994354bff9f85226e69cbef
parent9ea6a18e9913160e97375dd72fc74a8e5752ac40 (diff)
downloadguix-patches-75431d509b22ea8ba07ece596f404827ced742f7.tar
guix-patches-75431d509b22ea8ba07ece596f404827ced742f7.tar.gz
gnu: isl: Get source from SourceForge.
Reported by Artyom V. Poptsov <poptsov.artyom@gmail.com>. * gnu/packages/gcc.scm (isl)[home-page]: Update. [source]: Replace gforge.inria.fr URL with mirror://sourceforge URL. (isl-0.18)[source]: Likewise. (isl-0.11)[source]: Likewise.
-rw-r--r--gnu/packages/gcc.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index cd1635aff3..a6a5c6197d 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1171,12 +1171,11 @@ provides the GNU compiler for the Go programming language."))
(version "0.23")
(source (origin
(method url-fetch)
- (uri (list (string-append
- "http://isl.gforge.inria.fr/isl-"
- version
- ".tar.bz2")
+ ;; Used to be at isl.gforge.inria.fr.
+ (uri (list (string-append "mirror://sourceforge/libisl/isl-"
+ version ".tar.bz2")
(string-append %gcc-infrastructure
- name "-" version ".tar.bz2")))
+ "isl-" version ".tar.bz2")))
(sha256
(base32
"0k91zck10zxs9sk3yrbb92y1j3w981w3fbwkfwd7kl779b0j52f5"))))
@@ -1200,7 +1199,7 @@ provides the GNU compiler for the Go programming language."))
(("^old_library=.*")
"old_library=''\n"))))))))
(inputs (list gmp))
- (home-page "http://isl.gforge.inria.fr/")
+ (home-page "https://libisl.sourceforge.io/") ;https://repo.or.cz/w/isl.git
(synopsis
"Manipulating sets and relations of integer points \
bounded by linear constraints")
@@ -1221,7 +1220,7 @@ dependence analysis and bounds on piecewise step-polynomials.")
(version "0.18")
(source (origin
(method url-fetch)
- (uri (list (string-append "http://isl.gforge.inria.fr/isl-"
+ (uri (list (string-append "mirror://sourceforge/libisl/isl-"
version ".tar.bz2")
(string-append %gcc-infrastructure
"isl-" version ".tar.bz2")))
@@ -1236,12 +1235,10 @@ dependence analysis and bounds on piecewise step-polynomials.")
(version "0.11.1")
(source (origin
(method url-fetch)
- (uri (list (string-append
- "http://isl.gforge.inria.fr/isl-"
- version
- ".tar.bz2")
+ (uri (list (string-append "mirror://sourceforge/libisl/isl-"
+ version ".tar.bz2")
(string-append %gcc-infrastructure
- name "-" version ".tar.bz2")))
+ "isl-" version ".tar.bz2")))
(sha256
(base32
"13d9cqa5rzhbjq0xf0b2dyxag7pqa72xj9dhsa03m8ccr1a4npq9"))