summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-26 05:01:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-26 05:01:16 +0100
commit71a2d4176bdf7d88fd9d342b95ae74ed9685ec8d (patch)
tree8dc2041d6837f52f4b99eff6d938e468b9642258
parentea3f45a5a0d9f55ca1df2c7f9d9fd45d624dd1a1 (diff)
downloadguix-patches-71a2d4176bdf7d88fd9d342b95ae74ed9685ec8d.tar
guix-patches-71a2d4176bdf7d88fd9d342b95ae74ed9685ec8d.tar.gz
gnu: python-scandir: Update to 1.7.
* gnu/packages/python.scm (python-scandir): Update to 1.7. [description]: Mention that the Python3 variant is obsolete.
-rw-r--r--gnu/packages/python.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5b8c5081fc..64f48fd352 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11083,13 +11083,13 @@ It supports both normal and Unicode strings.")
(define-public python-scandir
(package
(name "python-scandir")
- (version "1.4")
+ (version "1.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "scandir" version))
(sha256
- (base32 "0yjrgp0mxp3d8bjkq2m1ac2ys8n76wykksvgyjrnil9gr3fx7a5d"))))
+ (base32 "0gbnhjzg42rj87ljv9kb648rfxph69ly3c8r9841dxy4d7l5pmdj"))))
(build-system python-build-system)
(home-page "https://github.com/benhoyt/scandir")
(synopsis "Directory iteration function")
@@ -11098,7 +11098,9 @@ It supports both normal and Unicode strings.")
returning a list of bare filenames, it yields DirEntry objects that include
file type and stat information along with the name. Using scandir() increases
the speed of os.walk() by 2-20 times (depending on the platform and file
-system) by avoiding unnecessary calls to os.stat() in most cases.")
+system) by avoiding unnecessary calls to os.stat() in most cases.
+
+This package is part of the Python standard library since version 3.5.")
(license license:bsd-3)))
(define-public python2-scandir