summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-01 01:14:04 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-19 00:56:29 +0100
commit55a680a6469369ac89cef958dac72080aaa4f9ad (patch)
treea81d4e9830446a60cade1925b50ab6468db1e9ab
parent3a68cf2b96b5bb89be9c083b1770285bfadca41a (diff)
downloadguix-patches-55a680a6469369ac89cef958dac72080aaa4f9ad.tar
guix-patches-55a680a6469369ac89cef958dac72080aaa4f9ad.tar.gz
gnu: Add wego.
* gnu/packages/weather.scm: New file. * gnu/local.mk: Register new file.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/weather.scm55
2 files changed, 56 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2911541275..4649ec6cd9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -604,6 +604,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/vulkan.scm \
%D%/packages/w3m.scm \
%D%/packages/wdiff.scm \
+ %D%/packages/weather.scm \
%D%/packages/web.scm \
%D%/packages/web-browsers.scm \
%D%/packages/webkit.scm \
diff --git a/gnu/packages/weather.scm b/gnu/packages/weather.scm
new file mode 100644
index 0000000000..6ba656017f
--- /dev/null
+++ b/gnu/packages/weather.scm
@@ -0,0 +1,55 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages weather)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system go)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages golang))
+
+(define-public wego
+ (package
+ (name "wego")
+ (version "2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/schachmat/wego")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bji9fywa0kg29zj1vrwq7l5f18hh0lcz6rl6sppi5id0qbjpiwl"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/schachmat/wego"))
+ (propagated-inputs
+ (list go-golang-org-x-sys
+ go-github-com-rivo-uniseg
+ go-github-com-mattn-go-isatty
+ go-github-com-schachmat-ingo
+ go-github-com-mattn-go-runewidth
+ go-github-com-mattn-go-colorable))
+ (home-page "https://github.com/schachmat/wego")
+ (synopsis "Weather client for the terminal")
+ (description "Wego is a weather client for the terminal. It shows
+forecast for one or seven days. Displayed information includes temperature
+range---felt and measured---, wind speed and direction, viewing distance,
+precipitation amount and probability.")
+ (license license:isc)))