summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-03-17 14:51:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-03-17 14:51:38 +0200
commite4b91f10c8d3912838e0d0f803f54363de9a3ca7 (patch)
tree13a3b2a28de36cb711b33358515ee39762374a6a
parentbae2201a8ddf789dff3f625327f5b2d0a686bc77 (diff)
downloadguix-patches-e4b91f10c8d3912838e0d0f803f54363de9a3ca7.tar
guix-patches-e4b91f10c8d3912838e0d0f803f54363de9a3ca7.tar.gz
gnu: python-scipy: Adjust phases.
* gnu/packages/python-science.scm (python-scipy)[arguments]: Replace 'check with custom 'check phase.
-rw-r--r--gnu/packages/python-science.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index e3e874dac2..e4aacdc072 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -157,10 +157,7 @@ atlas_libs = openblas
(tgt-dir (string-append html "/" dir)))
(install-file file html)))
(find-files ".")))))))
- ;; Tests can only be run after the library has been installed and not
- ;; within the source directory.
- (delete 'check)
- (add-after 'install 'check
+ (replace 'check
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)