summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-03-16 08:50:46 +0300
committerGuillaume Le Vaillant <glv@posteo.net>2022-03-16 16:48:11 +0100
commitd74d18437e5d18d19706fee52a4061e2a04aca48 (patch)
tree09e678020b7f2bfbf5e2aee8aac5865d2ffe0c60
parent4637b6952c31a0f124a448fa48ade26014a5e601 (diff)
downloadguix-patches-d74d18437e5d18d19706fee52a4061e2a04aca48.tar
guix-patches-d74d18437e5d18d19706fee52a4061e2a04aca48.tar.gz
gnu: i2pd: Update to 2.41.0.
* gnu/packages/i2p.scm (i2pd): Update to 2.41.0. [arguments]: Remove trailing slash to match all libi2pd entries. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/i2p.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm
index b945018ba8..2320250148 100644
--- a/gnu/packages/i2p.scm
+++ b/gnu/packages/i2p.scm
@@ -32,7 +32,7 @@
(define-public i2pd
(package
(name "i2pd")
- (version "2.38.0")
+ (version "2.41.0")
(source
(origin
(method git-fetch)
@@ -41,7 +41,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1a35grcfw5a9dsj0rnm2i86fjf4px96xbnjj3hkril7hv5jvl37k"))))
+ (base32 "0kh03lb4m8fvlfvq06d4hgwmk43pk7yp7n7y36kb2vplhrjrn2kx"))))
(build-system cmake-build-system)
(inputs
(list boost miniupnpc openssl zlib))
@@ -69,7 +69,7 @@
"./tests")
(with-directory-excursion "tests"
(substitute* "Makefile"
- (("../libi2pd/") (string-append source "/libi2pd/")))
+ (("../libi2pd") (string-append source "/libi2pd")))
(apply invoke "make" "all"
`(,@(if parallel-tests?
`("-j" ,(number->string