summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-03-14 16:16:28 -0400
committerGuillaume Le Vaillant <glv@posteo.net>2022-03-17 09:32:39 +0100
commitb999ce74baced2f729fd97f9df76d622ff47d6c8 (patch)
tree42483a0c8e29a0cbdbb05db7d2b15a6a7c0aa2bf
parent24f7c64bb2dc6b22b60f13d611d3721b13f310f5 (diff)
downloadguix-patches-b999ce74baced2f729fd97f9df76d622ff47d6c8.tar
guix-patches-b999ce74baced2f729fd97f9df76d622ff47d6c8.tar.gz
gnu: cl-envy: Update to 26a7faa.
* gnu/packages/lisp-xyz.scm (sbcl-envy): Update to 26a7faa. [native-inputs]: Uncomment test inputs and use new style. [arguments]: Add 'asd-systems' parameter, Remove 'fix-tests' phase. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm27
1 files changed, 10 insertions, 17 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 41ef89e7c3..4c015a7059 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12135,8 +12135,8 @@ carrys on from the end of the body.")
(sbcl-package->ecl-package sbcl-livesupport))
(define-public sbcl-envy
- (let ((commit "956321b2852d58ba71c6fe621f5c2924178e9f88")
- (revision "1"))
+ (let ((commit "26a7faadc981f2a047daa36f715a44faec5dd00c")
+ (revision "2"))
(package
(name "sbcl-envy")
(version (git-version "0.1" revision commit))
@@ -12145,26 +12145,19 @@ carrys on from the end of the body.")
(origin
(method git-fetch)
(uri (git-reference
- (url home-page)
+ (url "https://github.com/fukamachi/envy")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "cl-envy" version))
(sha256
- (base32 "17iwrfxcdinjbb2h6l09qf40s7xkbhrpmnljlwpjy8l8rll8h3vg"))))
+ (base32 "1r0wgimd7z57x8cv69sw76w3y5l70hq50882a9nq5l4v64lg55fq"))))
(build-system asdf-build-system/sbcl)
- ;; (native-inputs ; Only for tests.
- ;; `(("prove" ,sbcl-prove)
- ;; ("osicat" ,sbcl-osicat)))
+ (native-inputs
+ (list sbcl-osicat sbcl-prove))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
- (lambda _
- (substitute* "envy-test.asd"
- (("cl-test-more") "prove"))
- #t)))
- ;; Tests fail with
+ `(#:asd-systems '("envy-test" "envy")
+ ;; FIXME: Tests fail with
;; Component ENVY-ASD::ENVY-TEST not found, required by #<SYSTEM "envy">
- ;; like xsubseq. Why?
+ ;; https://github.com/fukamachi/envy/issues/10
#:tests? #f))
(synopsis "Common Lisp configuration switcher inspired by Perl's Config::ENV")
(description "Envy is a configuration manager for various applications.