summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-08 17:54:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-08 18:04:23 +0100
commitb03ee02f0d111bf75f8a87c9948c372974dcb243 (patch)
tree5c7376174e961253717c8754e8b24240587985ca
parentce7911ddae5d30ba73c8c9552b7d4e71268e5db3 (diff)
downloadguix-patches-b03ee02f0d111bf75f8a87c9948c372974dcb243.tar
guix-patches-b03ee02f0d111bf75f8a87c9948c372974dcb243.tar.gz
gnu: python-pandas: Fix build on 32-bit.
* gnu/packages/patches/python-pandas-skip-failing-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-pandas, python2-pandas): Use it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-pandas-skip-failing-tests.patch59
-rw-r--r--gnu/packages/python.scm4
3 files changed, 63 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 819fb4fcd3..4297cbb965 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -863,6 +863,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-statsmodels-fix-tests.patch \
%D%/packages/patches/python-configobj-setuptools.patch \
%D%/packages/patches/python-faker-fix-build-32bit.patch \
+ %D%/packages/patches/python-pandas-skip-failing-tests.patch \
%D%/packages/patches/python-paste-remove-website-test.patch \
%D%/packages/patches/python-paste-remove-timing-test.patch \
%D%/packages/patches/python-pygit2-disable-network-tests.patch \
diff --git a/gnu/packages/patches/python-pandas-skip-failing-tests.patch b/gnu/packages/patches/python-pandas-skip-failing-tests.patch
new file mode 100644
index 0000000000..31fc912d00
--- /dev/null
+++ b/gnu/packages/patches/python-pandas-skip-failing-tests.patch
@@ -0,0 +1,59 @@
+These tests fail on 32bit architectures.
+
+Upstream bug URL: https://github.com/pandas-dev/pandas/issues/14866
+
+--- a/pandas/tests/test_base.py 2017-03-08 17:49:44.422282717 +0100
++++ b/pandas/tests/test_base.py 2017-03-08 17:50:59.476701799 +0100
+@@ -363,30 +363,6 @@
+ self.assertFalse(result.iat[0])
+ self.assertFalse(result.iat[1])
+
+- def test_ndarray_compat_properties(self):
+-
+- for o in self.objs:
+-
+- # check that we work
+- for p in ['shape', 'dtype', 'flags', 'T', 'strides', 'itemsize',
+- 'nbytes']:
+- self.assertIsNotNone(getattr(o, p, None))
+- self.assertTrue(hasattr(o, 'base'))
+-
+- # if we have a datetimelike dtype then needs a view to work
+- # but the user is responsible for that
+- try:
+- self.assertIsNotNone(o.data)
+- except ValueError:
+- pass
+-
+- self.assertRaises(ValueError, o.item) # len > 1
+- self.assertEqual(o.ndim, 1)
+- self.assertEqual(o.size, len(o))
+-
+- self.assertEqual(Index([1]).item(), 1)
+- self.assertEqual(Series([1]).item(), 1)
+-
+ def test_ops(self):
+ for op in ['max', 'min']:
+ for o in self.objs:
+--- a/pandas/tools/tests/test_tile.py 2017-03-08 17:47:39.762261841 +0100
++++ b/pandas/tools/tests/test_tile.py 2017-03-08 17:48:26.831780495 +0100
+@@ -271,19 +271,6 @@
+ np.array([0, 0, 1, 1], dtype=np.int8))
+ tm.assert_numpy_array_equal(bins, np.array([0, 1.5, 3]))
+
+- def test_single_bin(self):
+- # issue 14652
+- expected = Series([0, 0])
+-
+- s = Series([9., 9.])
+- result = cut(s, 1, labels=False)
+- tm.assert_series_equal(result, expected)
+-
+- s = Series([-9., -9.])
+- result = cut(s, 1, labels=False)
+- tm.assert_series_equal(result, expected)
+-
+-
+ def curpath():
+ pth, _ = os.path.split(os.path.abspath(__file__))
+ return pth
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 76e6ead644..15c8a8eff4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1171,7 +1171,9 @@ datetime module, available in Python 2.3+.")
(method url-fetch)
(uri (pypi-uri "pandas" version))
(sha256
- (base32 "0540cnbwy2hc4hv2sxfs8i47xi91qzvzxfn80dl785ibiicly3vg"))))
+ (base32 "0540cnbwy2hc4hv2sxfs8i47xi91qzvzxfn80dl785ibiicly3vg"))
+ (patches
+ (search-patches "python-pandas-skip-failing-tests.patch"))))
(build-system python-build-system)
(propagated-inputs
`(("python-numpy" ,python-numpy)