summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-07 20:35:10 -0400
committerMark H Weaver <mhw@netris.org>2014-08-07 20:41:53 -0400
commitb087d413168a7e3632952f5d59a0c9b3515393ca (patch)
tree0d54cd41cde904ff4d58aef5e6afe49ae2a977e2
parent30016044e034945ae426e674880ba5e7485a48d0 (diff)
downloadguix-patches-b087d413168a7e3632952f5d59a0c9b3515393ca.tar
guix-patches-b087d413168a7e3632952f5d59a0c9b3515393ca.tar.gz
gnu: Add xsensors.
* gnu/packages/linux.scm (xsensors): New variable.
-rw-r--r--gnu/packages/linux.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 2dd4b383ab..bbc053129e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages maths)
#:use-module (gnu packages which)
#:use-module (gnu packages rrdtool)
+ #:use-module (gnu packages gtk)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -1441,3 +1442,40 @@ Wireless LAN specific parameters and get the specific stats.")
you to access information from temperature, voltage, and fan speed sensors.
It works with most newer systems.")
(license gpl2+)))
+
+(define-public xsensors
+ (package
+ (name "xsensors")
+ (version "0.70")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.linuxhardware.org/xsensors/xsensors-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1siplsfgvcxamyqf44h71jx6jdfmvhfm7mh0y1q8ps4zs6pj2zwh"))))
+ (build-system gnu-build-system)
+ (inputs `(("lm-sensors" ,lm-sensors)
+ ("gtk" ,gtk+-2)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:phases (alist-cons-before
+ 'configure 'enable-deprecated
+ (lambda _
+ (substitute* "src/Makefile.in"
+ (("-DGDK_DISABLE_DEPRECATED") "")
+ (("-DGTK_DISABLE_DEPRECATED") "")))
+ (alist-cons-before
+ 'configure 'remove-Werror
+ (lambda _
+ (substitute* '("configure" "src/Makefile.in")
+ (("-Werror") "")))
+ %standard-phases))))
+ (home-page "http://www.linuxhardware.org/xsensors/")
+ (synopsis "Hardware health information viewer")
+ (description
+ "xsensors reads data from the libsensors library regarding hardware
+health such as temperature, voltage and fan speed and displays the information
+in a digital read-out.")
+ (license gpl2+)))