summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-03-08 20:06:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-03-15 22:53:09 +0100
commit71ec67ef3f695a590f7f05f3e0b144434edda93b (patch)
tree27c91d99bd28e452dcbd6f00351994dcc37a7766
parent59978546fe7a31ea247a15ebd095adb6cffe7d55 (diff)
downloadguix-patches-71ec67ef3f695a590f7f05f3e0b144434edda93b.tar
guix-patches-71ec67ef3f695a590f7f05f3e0b144434edda93b.tar.gz
gnu: Add r-babelwhale.
* gnu/packages/cran.scm (r-babelwhale): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3d54eefd94..c9ee42e524 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -436,6 +436,28 @@ easier.")
for authoring journal articles and conference submissions.")
(license license:gpl3)))
+(define-public r-babelwhale
+ (package
+ (name "r-babelwhale")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "babelwhale" version))
+ (sha256
+ (base32 "0ph825dwvr48fhamy1l5564linz7cj7b9sj511as77f1yqycv4a2"))))
+ (properties `((upstream-name . "babelwhale")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-crayon r-dplyr r-dynutils r-processx r-purrr))
+ (home-page "https://github.com/dynverse/babelwhale")
+ (synopsis "Talking to Docker and Singularity containers")
+ (description
+ "This package provides a unified interface to interact with Docker and
+Singularity containers. You can execute a command inside a container, mount a
+volume or copy a file.")
+ (license license:expat)))
+
(define-public r-benchmarkmedata
(package
(name "r-benchmarkmedata")