summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-03-08 20:06:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-03-15 22:55:01 +0100
commit69af58e9a1e9886e774c598533c6e30241abc8f2 (patch)
treea2f0d49d74d9aa86ee76f44fdbff5ebd8ea48db7
parent76f96c891c273018fd7091cf51bfd11028957d6e (diff)
downloadguix-patches-69af58e9a1e9886e774c598533c6e30241abc8f2.tar
guix-patches-69af58e9a1e9886e774c598533c6e30241abc8f2.tar.gz
gnu: Add r-ga.
* gnu/packages/cran.scm (r-ga): New variable.
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9aa19dd2f5..ac0e160348 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1215,6 +1215,42 @@ experiment that allows a generic to warn if any arguments passed in @code{...}
are not used.")
(license license:gpl3)))
+(define-public r-ga
+ (package
+ (name "r-ga")
+ (version "3.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "GA" version))
+ (sha256
+ (base32 "135z03lnbj44jihnk6dii5a684jmc666ncpdwyyi910vl4sccib2"))))
+ (properties `((upstream-name . "GA")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-cli
+ r-crayon
+ r-foreach
+ r-iterators
+ r-rcpp
+ r-rcpparmadillo))
+ (native-inputs
+ (list r-knitr))
+ (home-page "https://luca-scr.github.io/GA/")
+ (synopsis "Genetic algorithms for stochastic optimisation")
+ (description
+ "Flexible general-purpose toolbox implementing genetic algorithms (GAs)
+for stochastic optimisation. Binary, real-valued, and permutation
+representations are available to optimize a fitness function, i.e., a function
+provided by users depending on their objective function. Several genetic
+operators are available and can be combined to explore the best settings for
+the current task. Furthermore, users can define new genetic operators and
+easily evaluate their performances. Local search using general-purpose
+optimisation algorithms can be applied stochastically to exploit interesting
+regions. GAs can be run sequentially or in parallel, using an explicit
+master-slave parallelisation or a coarse-grain islands approach.")
+ (license license:gpl2+)))
+
(define-public r-grr
(package
(name "r-grr")