summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-03-08 20:06:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-03-15 22:52:37 +0100
commit59978546fe7a31ea247a15ebd095adb6cffe7d55 (patch)
tree6aaed048e6a649d715d25c082f4716496494bb92
parentfdbc472bd1c8b15195192196f1ef049fe3094110 (diff)
downloadguix-patches-59978546fe7a31ea247a15ebd095adb6cffe7d55.tar
guix-patches-59978546fe7a31ea247a15ebd095adb6cffe7d55.tar.gz
gnu: Add r-polychrome.
* gnu/packages/cran.scm (r-polychrome): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b231e7ed61..3d54eefd94 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1097,6 +1097,30 @@ does not use formula input or special syntax, but can be used in combination
with default R plot functions.")
(license license:gpl2+)))
+(define-public r-polychrome
+ (package
+ (name "r-polychrome")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Polychrome" version))
+ (sha256
+ (base32 "044vbylgbqf0ccv4r15nmbw1vz0j95g67i6blw73hvbvbm6w5x4d"))))
+ (properties `((upstream-name . "Polychrome")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-colorspace r-scatterplot3d))
+ (native-inputs
+ (list r-knitr))
+ (home-page "http://oompa.r-forge.r-project.org/")
+ (synopsis "Qualitative palettes with many colors")
+ (description
+ "This package provides tools for creating, viewing, and assessing
+qualitative palettes with many (20-30 or more) colors. See Coombes and
+colleagues (2019) @url{https://doi:10.18637/jss.v090.c01}.")
+ (license license:asl2.0)))
+
(define-public r-ecp
(package
(name "r-ecp")