summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@tutanota.com>2022-03-15 13:20:00 -0400
committerLeo Famulari <leo@famulari.name>2022-03-15 20:01:33 -0400
commit53370c7b03b1302e7c84781184fe52a8f6c315c5 (patch)
tree8f15adc9114f271e8027f7abe5ad98c87226fc65
parent8a0713aef2a8d709551d51fefff45f4611d05c66 (diff)
downloadguix-patches-53370c7b03b1302e7c84781184fe52a8f6c315c5.tar
guix-patches-53370c7b03b1302e7c84781184fe52a8f6c315c5.tar.gz
gnu: httpie: Update to 3.1.0 [security fixes].
Fixes CVE-2022-24737 and CVE-2022-0430. * gnu/packages/python-web.scm (httpie): Update to 3.1.0. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python-web.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 240c58b665..466d9782ca 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -748,14 +748,14 @@ other HTTP libraries.")
(define-public httpie
(package
(name "httpie")
- (version "3.0.2")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "httpie" version))
(sha256
(base32
- "16ay8mx2v1z3rywsszy055l5k50qjiwyc3pds5wxxzd1n9a79w97"))))
+ "1npyfvrq0l56bil8rnpj78mav378mxx4zcqzq1jjx4aap1020jif"))))
(build-system python-build-system)
(arguments
;; The tests attempt to access external web servers, so we cannot run them.