summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyrill Schenkel <cyrill.schenkel@gmail.com>2014-06-29 10:23:28 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-29 22:36:37 +0200
commit009c5b5cdc6c7bee0ac6684c7c151d544dffe2ad (patch)
treee65d01dd6e29701e493dbdb0ba70ad86a37b3964
parent081c5b2d66b6f9bdd1b966a96640b7ec4df8d5a6 (diff)
downloadguix-patches-009c5b5cdc6c7bee0ac6684c7c151d544dffe2ad.tar
guix-patches-009c5b5cdc6c7bee0ac6684c7c151d544dffe2ad.tar.gz
gnu: Add ncmpcpp.
* gnu/packages/mpd.scm (ncmpcpp): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/mpd.scm28
1 files changed, 27 insertions, 1 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 5841e8be7b..a20103df4f 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,7 +40,8 @@
#:use-module (gnu packages xiph)
#:export (libmpdclient
mpd
- ncmpc))
+ ncmpc
+ ncmpcpp))
(define libmpdclient
(package
@@ -147,3 +149,27 @@ protocol.")
terminal using ncurses.")
(home-page "http://www.musicpd.org/clients/ncmpc/")
(license license:gpl2)))
+
+(define ncmpcpp
+ (package
+ (name "ncmpcpp")
+ (version "0.5.10")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://ncmpcpp.rybczak.net/stable/ncmpcpp-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1a54g6dary1rirrny9fd0hpxpyyffypni3mpbdpvmjnrl9v56vgz"))))
+ (build-system gnu-build-system)
+ (inputs `(("libmpdclient" ,libmpdclient)
+ ("ncurses" ,ncurses)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "Featureful ncurses based MPD client inspired by ncmpc")
+ (description "Ncmpcpp is an mpd client with a UI very similar to ncmpc,
+but it provides new useful features such as support for regular expressions
+for library searches, extended song format, items filtering, the ability to
+sort playlists, and a local filesystem browser.")
+ (home-page "http://ncmpcpp.rybczak.net/")
+ (license license:gpl2+)))