summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-09 15:28:15 +0000
committerLeo Famulari <leo@famulari.name>2021-10-16 17:32:24 -0400
commitf2acd45eae3697c798716e6b99c32565babbf70f (patch)
tree11d3b5bdf5ffe0c3ded30dee61e0da246c72d01f
parent5ced0440ed74607fb12bf28386fff4c34beac47e (diff)
downloadguix-patches-f2acd45eae3697c798716e6b99c32565babbf70f.tar
guix-patches-f2acd45eae3697c798716e6b99c32565babbf70f.tar.gz
gnu: Add libdjinterop.
* gnu/packages/audio.scm (libdjinterop): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/audio.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ef06e0934e..4712e9aa72 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -107,6 +107,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
#:use-module (gnu packages serialization)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages telephony)
#:use-module (gnu packages linphone)
#:use-module (gnu packages linux)
@@ -1217,6 +1218,40 @@ flanger), ringmodulator, distortion, filters, pitchshift, oscillators,
emulation (valve, tape), bit fiddling (decimator, pointer-cast), etc.")
(license license:gpl3+)))
+(define-public libdjinterop
+ (package
+ (name "libdjinterop")
+ (version "0.16.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xsco/libdjinterop")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16nrqpr90vb9ggmp9j73m0hspd7pmfdhh0g6iyp8vd7kx7g17qnk"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; crate_test writes a database file to the source tree.
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files ".")))))))
+ (native-inputs
+ `(("boost" ,boost)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/xsco/libdjinterop")
+ (synopsis "C++ library for access to DJ record libraries")
+ (description
+ "@code{libdjinterop} is a C++ library that allows access to database
+formats used to store information about DJ record libraries.")
+ (license license:lgpl3+)))
+
(define-public tao
(package
(name "tao")