summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-03-14 09:26:04 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-14 23:32:19 +0100
commite86293d250add87121ec7c1f02f0367632c389d8 (patch)
tree7ed16e3871f22e01c3aa55028013563282b81b06
parenta359f3a49cce26997ff85bcbfc0059450ff90e0f (diff)
downloadguix-patches-e86293d250add87121ec7c1f02f0367632c389d8.tar
guix-patches-e86293d250add87121ec7c1f02f0367632c389d8.tar.gz
gnu: ocaml-lacaml: Do not build with "-march=native".
* gnu/packages/ocaml.scm (ocaml-lacaml)[origin]: Add 'snippet'. [properties]: New field.
-rw-r--r--gnu/packages/ocaml.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index fff85a6de2..78eab203de 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6925,7 +6925,11 @@ library FFTW.")
(file-name (git-file-name name version))
(sha256
(base32
- "115535kphchh2a434b48b408x9794j8zzrsdmacsgqdsrgy3rck4"))))
+ "115535kphchh2a434b48b408x9794j8zzrsdmacsgqdsrgy3rck4"))
+ (modules '((guix build utils)))
+ (snippet '(substitute* '("src/dune" "src/config/dune")
+ (("-march=native") "")))))
+ (properties '((tunable? . #t)))
(build-system dune-build-system)
(arguments
`(#:tests? #f)) ; No test target.