summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-22 20:08:11 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:19 -0400
commit8d52b4e0e1d6291076eae752c135155a427abc76 (patch)
treef9c0a8e5b6774bac56ec3ae0eb6a95bc4d122de1
parentd03fa9aa926266fcc4652a6ce14b47f2887815a5 (diff)
downloadguix-patches-8d52b4e0e1d6291076eae752c135155a427abc76.tar
guix-patches-8d52b4e0e1d6291076eae752c135155a427abc76.tar.gz
gnu: Add go-github-com-dchest-siphash.
* gnu/packages/golang.scm (go-github-com-dchest-siphash): New variable. Co-authored-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6622302a71..847078a704 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,29 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-dchest-siphash
+ (package
+ (name "go-github-com-dchest-siphash")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/dchest/siphash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08s076y7vmjqnq7jz0762hkm896r6r31v8b31a3gy0n8rfa01k8k"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/dchest/siphash"))
+ (home-page "https://github.com/dchest/siphash")
+ (synopsis "Go library for pseudorandom functions")
+ (description "SipHash is a family of pseudorandom functions (PRFs) optimized
+for speed on short messages.")
+ (license license:cc0)))
+
(define-public go-github-com-rakyll-statik
(package
(name "go-github-com-rakyll-statik")