summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-24 20:07:16 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:21 -0400
commit68bfec63c247436265f7e9c17320e0ef9fdfdd63 (patch)
tree8c37ebf2f5e647f5cc711f1cca9c02db61b72468
parent19f3b7c7b8ccd157999d004f0054c9e6217db5c0 (diff)
downloadguix-patches-68bfec63c247436265f7e9c17320e0ef9fdfdd63.tar
guix-patches-68bfec63c247436265f7e9c17320e0ef9fdfdd63.tar.gz
gnu: Add go-github-com-mufti1-interconv.
* gnu/packages/golang.scm (go-github-com-mufti1-interconv): New variable.
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a33178b99d..9f7a522a51 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,31 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-mufti1-interconv
+ (let ((commit "d7c72925c6568d60d361757bb9f2d252dcca745c")
+ (revision "0"))
+ (package
+ (name "go-github-com-mufti1-interconv")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mufti1/interconv")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13f5pvr74afa28pbpmgvjzjx68vv5zmrwlvxp7hr5bl5625zlxmy"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:unpack-path "github.com/mufti1/interconv"
+ #:import-path "github.com/mufti1/interconv/package"))
+ (home-page "https://github.com/mufti1/interconv")
+ (synopsis "Data type converter")
+ (description "InterConv converts interfaces into any data type.")
+ (license license:expat))))
+
(define-public go-github-com-opentracing-opentracing-go
(package
(name "go-github-com-opentracing-opentracing-go")