summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-23 18:49:03 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:19 -0400
commit520eaa48af80e35b00e6e01173a912b0becc5684 (patch)
treee761c790fb85b883edb2b504dbb338eb42dc0f65
parent24487f2ddc2e2a4cc1bd6062d1eb10ec518fcaa2 (diff)
downloadguix-patches-520eaa48af80e35b00e6e01173a912b0becc5684.tar
guix-patches-520eaa48af80e35b00e6e01173a912b0becc5684.tar.gz
gnu: Add go-github-com-sevlyar-go-daemon.
* gnu/packages/golang.scm (go-github-com-sevlyar-go-daemon): New variable.
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ad90ac4473..2445a51689 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,30 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-sevlyar-go-daemon
+ (package
+ (name "go-github-com-sevlyar-go-daemon")
+ (version "0.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/sevlyar/go-daemon")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y3gnxaifykcjcbzx91lz9bc93b95w3xj4rjxjbii26pm3j7gqyk"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/sevlyar/go-daemon"))
+ (propagated-inputs
+ `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+ (home-page "https://github.com/sevlyar/go-daemon")
+ (synopsis "Library for writing system daemons")
+ (description "Go-Daemon is a library for writing system daemons in Go.")
+ (license license:expat)))
+
(define-public go-github-com-keybase-go-ps
(let ((commit "91aafc93ba19d1988cff338c1929d35b6c6f5b50")
(revision "0"))