summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-10-26 21:28:58 +0200
committerLudovic Courtès <ludo@gnu.org>2021-12-12 00:27:54 +0100
commit8a1de8943269bc438dee53defaed7ed4422c0330 (patch)
treec18d763ccd2a0245b78b6ac8fa9d1a8c11c864ce
parentea18b4c5298c8cdcea22472f8cf8ce8fb3180a78 (diff)
downloadguix-patches-8a1de8943269bc438dee53defaed7ed4422c0330.tar
guix-patches-8a1de8943269bc438dee53defaed7ed4422c0330.tar.gz
gnu: Add python-ipaddress.
* gnu/packages/python-xyz.scm (python-ipaddress): New variable; (python2-ipaddress): Use package-with-python2. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db2ab8e5f0..701ff31990 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11419,9 +11419,9 @@ implementations of ASN.1-based codecs and protocols.")
(define-public python2-pyasn1-modules
(package-with-python2 python-pyasn1-modules))
-(define-public python2-ipaddress
+(define-public python-ipaddress
(package
- (name "python2-ipaddress")
+ (name "python-ipaddress")
(version "1.0.23")
(source (origin
(method url-fetch)
@@ -11430,17 +11430,17 @@ implementations of ASN.1-based codecs and protocols.")
(base32
"1qp743h30s04m3cg3yk3fycad930jv17q7dsslj4mfw0jlvf1y5p"))))
(build-system python-build-system)
- (arguments
- `(#:python ,python-2))
(home-page "https://github.com/phihag/ipaddress")
(synopsis "IP address manipulation library")
(description
"This package provides a fast, lightweight IPv4/IPv6 manipulation library
in Python. This library is used to create, poke at, and manipulate IPv4 and
- IPv6 addresses and networks. This is a port of the Python 3.3 ipaddress
- module to older versions of Python.")
+ IPv6 addresses and networks.")
(license license:psfl)))
+(define-public python2-ipaddress
+ (package-with-python2 python-ipaddress))
+
(define-public python-asn1tools
(package
(name "python-asn1tools")