summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-12 19:23:09 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-12 19:23:09 +0100
commit504d15a593faf06ed502057406a20b3601e12759 (patch)
tree598fbe59b97bad1eba0d9a91c1bd8ec273cd8ced
parent33331efc464d117538ca8f1e9628bf8943e2c9f9 (diff)
downloadguix-patches-504d15a593faf06ed502057406a20b3601e12759.tar
guix-patches-504d15a593faf06ed502057406a20b3601e12759.tar.gz
gnu: denemo: Honor TESTS?.
* gnu/packages/music.scm (denemo)[arguments]<#:phases>: Honor TESTS? keyword.
-rw-r--r--gnu/packages/music.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d82e904490..25f2495c02 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -632,16 +632,17 @@ many input formats and provides a customisable Vi-style user interface.")
#:phases
#~(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda* (#:key inputs tests? #:allow-other-keys)
;; Tests require to write $HOME.
- (setenv "HOME" (getcwd))
- ;; Replace hard-coded diff file name.
- (substitute* "tests/integration.c"
- (("/usr/bin/diff")
- (search-input-file inputs "/bin/diff")))
- ;; Denemo's documentation says to use this command to run its
- ;; test suite.
- (invoke "make" "-C" "tests" "check")))
+ (when tests?
+ (setenv "HOME" (getcwd))
+ ;; Replace hard-coded diff file name.
+ (substitute* "tests/integration.c"
+ (("/usr/bin/diff")
+ (search-input-file inputs "/bin/diff")))
+ ;; Denemo's documentation says to use this command to run its
+ ;; test suite.
+ (invoke "make" "-C" "tests" "check"))))
(add-before 'build 'set-lilypond
;; This phase sets the default path for lilypond to its current
;; location in the store.