summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-03-04 13:01:10 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-11 23:34:48 -0500
commit1879d6d810ca520b1705e20e95571fec95ae43fd (patch)
tree8e66b31684add494aed627c5432cf77f6c1feba5
parent4b5b3b8eb2739ec6c051fe7ce31bd86446bd3526 (diff)
downloadguix-patches-1879d6d810ca520b1705e20e95571fec95ae43fd.tar
guix-patches-1879d6d810ca520b1705e20e95571fec95ae43fd.tar.gz
gnu: ecl: Run tests conditionally and please lint.
* gnu/packages/lisp.scm (ecl)[source]: Adjust origin URL. [inputs]: Add bash-minimal. [arguments]: Move the comment about failing tests above the deleted check phase. [tests?]: Do not explicitly set to #t. [phases]: Delete trailing #t. [home-page]: Update. Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/lisp.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index edca4e632a..01d71086a5 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -251,7 +251,7 @@ interface to the Tk widget system.")
(origin
(method url-fetch)
(uri (string-append
- "https://common-lisp.net/project/ecl/static/files/release/"
+ "https://ecl.common-lisp.dev/static/files/release/"
name "-" version ".tgz"))
(sha256
(base32 "000906nnq25177bgsfndiw3iqqgrjc9spk10hzk653sbz3f7anmi"))))
@@ -259,6 +259,7 @@ interface to the Tk widget system.")
;; src/configure uses 'which' to confirm the existence of 'gzip'.
(native-inputs
(list cl-asdf which texinfo))
+ (inputs (list bash-minimal))
;; When ECL is embedded in a program that wants to use Common Lisp as an
;; extension language, libgmp, libatomic-ops, libgc and libffi must be
;; present when compiling the program because they are required by ECL's
@@ -269,12 +270,11 @@ interface to the Tk widget system.")
(list gmp libatomic-ops libgc libffi))
(arguments
`(#:configure-flags '("--without-rt")
- ;; FIXME: As of version 20.4.24, we pass 17995 tests and fail 7.
- ;; 2-3 tests may be due to FHS assumptions.
- #:tests? #t
#:parallel-tests? #f
#:phases
(modify-phases %standard-phases
+ ;; FIXME: As of version 20.4.24, we pass 17995 tests and fail 7.
+ ;; 2-3 tests may be due to FHS assumptions.
(delete 'check)
(add-after 'unpack 'replace-asdf
;; Use system ASDF instead of bundled one.
@@ -284,13 +284,11 @@ interface to the Tk widget system.")
cl-asdf
"/share/common-lisp/source/asdf/asdf.lisp"))
(contrib-asdf "contrib/asdf/asdf.lisp"))
- (copy-file guix-asdf contrib-asdf))
- #t))
+ (copy-file guix-asdf contrib-asdf))))
(add-after 'install 'remove-build-stamp
(lambda* (#:key outputs #:allow-other-keys)
(delete-file (string-append (assoc-ref outputs "out")
- "/lib/ecl-" ,version "/build-stamp"))
- #t))
+ "/lib/ecl-" ,version "/build-stamp"))))
(add-after 'remove-build-stamp 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((ecl (assoc-ref outputs "out"))
@@ -313,14 +311,12 @@ interface to the Tk widget system.")
(input-path lib "/include"))
`("kernel-headers" ,@libraries)))
`("LIBRARY_PATH" suffix ,library-directories)
- `("LD_LIBRARY_PATH" suffix ,library-directories))
- #t)))
+ `("LD_LIBRARY_PATH" suffix ,library-directories)))))
(add-after 'wrap 'check (assoc-ref %standard-phases 'check))
(add-before 'check 'fix-path-to-ecl
(lambda _
(substitute* "build/tests/Makefile"
- (("\\$\\{exec_prefix\\}/") ""))
- #t)))))
+ (("\\$\\{exec_prefix\\}/") "")))))))
(native-search-paths
(list (search-path-specification
(variable "XDG_DATA_DIRS")
@@ -328,7 +324,7 @@ interface to the Tk widget system.")
(search-path-specification
(variable "XDG_CONFIG_DIRS")
(files '("etc")))))
- (home-page "http://ecls.sourceforge.net/")
+ (home-page "https://ecl.common-lisp.dev/")
(synopsis "Embeddable Common Lisp")
(description "ECL is an implementation of the Common Lisp language as
defined by the ANSI X3J13 specification. Its most relevant features are: a