summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-03-12 13:24:56 +0100
committerMathieu Othacehe <othacehe@gnu.org>2022-03-12 13:26:18 +0100
commitb9b263d3509984b42c5dfdd4fe039a25f1af658c (patch)
treef5a6549527e24052911430191c0d48ec90205351
parentf6fa20f9237c185b4e887a343cd19aa37855aed9 (diff)
downloadguix-patches-b9b263d3509984b42c5dfdd4fe039a25f1af658c.tar
guix-patches-b9b263d3509984b42c5dfdd4fe039a25f1af658c.tar.gz
gnu: lemonbar-xft: Fix build.
* gnu/packages/wm.scm (lemonbar-xft)[arguments]: Fix the make-flags keyword that now inherits from the lemonbar gexp make-flags keyword.
-rw-r--r--gnu/packages/wm.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8a691f24b3..3de760d7a6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2304,17 +2304,12 @@ wasting your precious memory.")
(arguments
(substitute-keyword-arguments (package-arguments lemonbar)
((#:make-flags make-flags)
- `(append
- ,make-flags
- (list (string-append
- "CFLAGS="
- (string-join
- (list (string-append
- "-I" (assoc-ref %build-inputs "freetype")
- "/include/freetype2")
- (string-append
- "-D" "VERSION="
- (format #f "'~s'" ,version))))))))))
+ #~(#$@make-flags
+ (format #f "CFLAGS=~a -DVERSION='~s'"
+ (string-append
+ "-I" #$(this-package-input "freetype")
+ "/include/freetype2")
+ #$version)))))
(home-page "https://github.com/drscream/lemonbar-xft")
(synopsis
(string-append