summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-04 22:43:10 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:34 -0500
commitef347195278eb160ec725bbdccf71d67c0fa4271 (patch)
treeed3cc2728603e481f96c89e9ffd1555de94becc3
parentb045f587715f9dc11e71e267f1cf4c8fd24ae4dc (diff)
downloadguix-patches-ef347195278eb160ec725bbdccf71d67c0fa4271.tar
guix-patches-ef347195278eb160ec725bbdccf71d67c0fa4271.tar.gz
gnu: python-pymodbus: Update to 2.5.3.
* gnu/packages/python-xyz.scm (python-pymodbus): Update to 2.5.3. [phases]{disable-problematic-tests}: Delete an extra test module. [native-inputs]: Remove python-asynctest.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ecf97cda70..a50c368d53 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16298,7 +16298,7 @@ support.")
(define-public python-pymodbus
(package
(name "python-pymodbus")
- (version "2.5.2")
+ (version "2.5.3")
(source
(origin
(method git-fetch)
@@ -16308,24 +16308,28 @@ support.")
(file-name (git-file-name name version))
(sha256
(base32
- "009blvzi56434f0qfjdg3r8q1flb1jcx2786wi0i0xf81025z9cf"))))
+ "0kjjrx7xrlx0pf3y67hhr4xvqrly3xzmvf6ic5as61m6z19m7zd5"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'unpack 'disable-problematic-tests
(lambda _
- ;; The following test module rely on Python's own 'test'
- ;; module, which is not distributed in the Python
+ ;; The following test modules rely on Python's own
+ ;; 'test' module, which is not distributed in the Python
;; package of Guix.
(delete-file "test/test_client_async_asyncio.py")
- (delete-file "test/test_client_sync_diag.py")))
+ (delete-file "test/test_client_sync_diag.py")
+ ;; The following test module requires the asynctest
+ ;; library, abandoned without support for Python 3.9+
+ ;; (see:
+ ;; https://github.com/riptideio/pymodbus/issues/681).
+ (delete-file "test/test_server_asyncio.py")))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "python" "-m" "pytest")))))))
(native-inputs
- `(("python-asynctest" ,python-asynctest)
- ("python-mock" ,python-mock)
+ `(("python-mock" ,python-mock)
("python-pytest" ,python-pytest)
("python-redis" ,python-redis)
("python-sqlalchemy" ,python-sqlalchemy)