summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-04 13:52:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-12 11:57:26 +0300
commite7ffbe2fda64d4a399ca325bc446df0837be1844 (patch)
tree03854fca103e33a70e2c1cd8ea5c7c4dca684edc
parent9c6301319ea80eca661c65ec05c68c579bb2d104 (diff)
downloadguix-patches-e7ffbe2fda64d4a399ca325bc446df0837be1844.tar
guix-patches-e7ffbe2fda64d4a399ca325bc446df0837be1844.tar.gz
gnu: Add rust-matches.
* gnu/packages/crates-io.scm (rust-matches): New variable.
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7c9c2acef1..0e379fbdb9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -333,6 +333,25 @@ friction with idiomatic Rust structs to ease interopability.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-matches
+ (package
+ (name "rust-matches")
+ (version "0.1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "matches" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "020axl4q7rk9vz90phs7f8jas4imxal9y9kxl4z4v7a6719mrz3z"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/SimonSapin/rust-std-candidates")
+ (synopsis "Macro to evaluate whether an expression matches a pattern.")
+ (description "This package provides a macro to evaluate, as a boolean,
+whether an expression matches a pattern.")
+ (license license:expat)))
+
(define-public rust-proc-macro2
(package
(name "rust-proc-macro2")