summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-14 22:25:09 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-15 16:33:08 -0500
commitbafe510b3ed377c606dcd372a85ddba6324f8c6f (patch)
tree804f5b8bd67ebc26e1bdd8e0e814167a9e12fc4b
parentbe7061cea30b59676fc473d6bd4a56a0f2fbd7cf (diff)
downloadguix-patches-bafe510b3ed377c606dcd372a85ddba6324f8c6f.tar
guix-patches-bafe510b3ed377c606dcd372a85ddba6324f8c6f.tar.gz
gnu: python-mccabe: Add missing python-toml input.
* gnu/packages/python-xyz.scm (python-mccabe)[native-inputs]: Add python-toml. [home-page]: Update home page.
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5cadeda52c..432ff39f23 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8261,9 +8261,10 @@ PEP 8.")
"07w3p1qm44hgxf3vvwz84kswpsx6s7kvaibzrsx5dzm0hli1i3fx"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest-bootstrap)
+ `(("python-toml", python-toml)
+ ("python-pytest" ,python-pytest-bootstrap)
("python-pytest-runner" ,python-pytest-runner)))
- (home-page "https://github.com/flintwork/mccabe")
+ (home-page "https://github.com/PyCQA/mccabe")
(synopsis "McCabe checker, plugin for flake8")
(description
"This package provides a Flake8 plug-in to compute the McCabe cyclomatic