summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-04 22:44:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:34 -0500
commitb89ab98168a988ba305c30004934f19aaf67bba6 (patch)
tree855eb2ad494fac3db98f0b22c893c589905852af
parentef347195278eb160ec725bbdccf71d67c0fa4271 (diff)
downloadguix-patches-b89ab98168a988ba305c30004934f19aaf67bba6.tar
guix-patches-b89ab98168a988ba305c30004934f19aaf67bba6.tar.gz
gnu: python-asynctest: Delete package.
This library is no longer supported (doesn't build with Python 3.9; see https://github.com/Martiusweb/asynctest/issues/158). * gnu/packages/python-xyz.scm (python-aionotify): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a50c368d53..1e1c4d0a84 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24042,50 +24042,6 @@ memoization.")
Notation (CSON).")
(license license:expat)))
-(define-public python-asynctest
- (package
- (name "python-asynctest")
- (version "0.13.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "asynctest" version))
- (sha256
- (base32
- "1b3zsy7p84gag6q8ai2ylyrhx213qdk2h2zb6im3xn0m5n264y62"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "python" "-X" "dev" "-m" "unittest" "-v" "test")))
- (add-after 'unpack 'disable-tests
- (lambda* _
- ;; XXX: 7 tests fail out of 220. Disable them for now.
- (substitute* (list "test/test_selector.py"
- "test/test_mock.py")
- (("def test_events_watched_outside_test_are_ignored")
- "@unittest.skip('disabled by guix')
- def test_events_watched_outside_test_are_ignored")
- (("def test_awaited_from_autospec_mock.*" line)
- (string-append line " return True\n"))
- (("def test_create_autospec_on_coroutine_and_using_assert_methods.*" line)
- (string-append line " return True\n"))
- (("def test_patch_coroutine_with_multiple_scopes.*" line)
- (string-append line " return True\n"))
- (("def test_multiple_patches_on_coroutine.*" line)
- (string-append line " return True\n"))
- (("def test_patch_coroutine_only_when_running.*" line)
- (string-append line " return True\n")))
- #t)))))
- (home-page "https://github.com/Martiusweb/asynctest")
- (synopsis "Extension of unittest for testing asyncio libraries")
- (description
- "The package asynctest is built on top of the standard unittest module
-and cuts down boilerplate code when testing libraries for asyncio.")
- (license license:asl2.0)))
-
(define-public python-aionotify
(package
(name "python-aionotify")