summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-02 19:31:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-11-12 16:14:42 +0200
commitb2e93b9e4522816e8959016ef5c22b2ccd9699a2 (patch)
treee71d39a7c29edc8993125b47405316fad92aee84
parent9e81af9e72651cc4fdc700b29c44beb18a3743ba (diff)
downloadguix-patches-b2e93b9e4522816e8959016ef5c22b2ccd9699a2.tar
guix-patches-b2e93b9e4522816e8959016ef5c22b2ccd9699a2.tar.gz
gnu: Add owncloud-client.
* gnu/packages/owncloud.scm (owncloud-client): New variable. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/owncloud.scm80
2 files changed, 81 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 0b716c76ab..3378fa77ea 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -241,6 +241,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/openstack.scm \
gnu/packages/orpheus.scm \
gnu/packages/ots.scm \
+ gnu/packages/owncloud.scm \
gnu/packages/package-management.scm \
gnu/packages/parallel.scm \
gnu/packages/password-utils.scm \
diff --git a/gnu/packages/owncloud.scm b/gnu/packages/owncloud.scm
new file mode 100644
index 0000000000..58c2a51ba8
--- /dev/null
+++ b/gnu/packages/owncloud.scm
@@ -0,0 +1,80 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages owncloud)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages databases)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages ruby)
+ #:use-module (gnu packages tls))
+
+(define-public owncloud-client
+ (package
+ (name "owncloud-client")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.owncloud.com/desktop/stable/"
+ "owncloudclient-" version ".tar.xz"))
+ (sha256
+ (base32 "0a42nqx0gn10n7ikhxwif0lqddmb6gbvr45bqbbl30an9gixq598"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-rpath-dirs
+ (lambda _
+ (substitute* '("src/libsync/CMakeLists.txt"
+ "csync/src/CMakeLists.txt")
+ ;; We store the libs in out/lib and not /usr/lib/appname, so we
+ ;; need the executable to point to the libraries in /lib and not
+ ;; in /lib/appname.
+ (("\\/\\$\\{APPLICATION_EXECUTABLE\\}") ""))
+ (substitute* '("src/cmd/CMakeLists.txt"
+ "src/crashreporter/CMakeLists.txt"
+ "src/gui/CMakeLists.txt")
+ ;; This has the same issue as the substitution above.
+ (("\\/\\$\\{APPLICATION_EXECUTABLE\\}\\\"") "\"")))))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("inotify-tools" ,inotify-tools)
+ ("openssl" ,openssl)
+ ("perl" ,perl)
+ ("python-wrapper" ,python-wrapper)
+ ("qt" ,qt)
+ ("qtkeychain" ,qtkeychain)
+ ("ruby" ,ruby)
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ (home-page "https://owncloud.org")
+ (synopsis "Folder synchronization with an ownCloud server")
+ (description "The ownCloudSync system lets you always have your latest
+files wherever you are. Just specify one or more folders on the local machine
+to and a server to synchronize to. You can configure more computers to
+synchronize to the same server and any change to the files on one computer will
+silently and reliably flow across to every other.")
+ (license license:gpl2+)))