summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2022-03-08 10:52:08 -0500
committerLudovic Courtès <ludo@gnu.org>2022-03-11 23:15:43 +0100
commita05fb56c6e0edcd823b3df82a54ace46e82a03be (patch)
tree86053cb1f3af46d7bdc9a826c7ce40820791f4fd
parentb3b9b680403add768763cc65b1e67815c489989f (diff)
downloadguix-patches-a05fb56c6e0edcd823b3df82a54ace46e82a03be.tar
guix-patches-a05fb56c6e0edcd823b3df82a54ace46e82a03be.tar.gz
gnu: ucsim: Don't explicitly return #t from phases.
* gnu/packages/embedded.scm (ucsim)[arguments]: Don't explicitly return #t from phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/embedded.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 24d454820b..021ce8c3fa 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1507,13 +1507,11 @@ handling communication with eBUS devices connected to a 2-wire bus system
(add-after 'unpack 'patch-makefiles
(lambda _
(substitute* (find-files "." "(\\.mk$|\\.in$)")
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(add-after 'install 'remove-empty-directory
(lambda* (#:key outputs #:allow-other-keys)
(delete-file-recursively
- (string-append (assoc-ref outputs "out") "/share/man"))
- #t)))))
+ (string-append (assoc-ref outputs "out") "/share/man")))))))
(native-inputs
(list bison flex))
(home-page "http://mazsola.iit.uni-miskolc.hu/ucsim/")